lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Thu, 30 Oct 2014 02:34:52 +0000
From:	"Anson.Huang@...escale.com" <Anson.Huang@...escale.com>
To:	Fabio Estevam <festevam@...il.com>,
	"fugang.duan@...escale.com" <fugang.duan@...escale.com>
CC:	"Frank.Li@...escale.com" <Frank.Li@...escale.com>,
	Russell King <linux@....linux.org.uk>,
	Shawn Guo <shawn.guo@...aro.org>,
	"netdev@...r.kernel.org" <netdev@...r.kernel.org>
Subject: RE: suspend/resume broken on 3.18-rc2

Hi, all
	I just tried the 3.18.0-rc2 on our i.MX6SX-SDB board, attached is my log, seems like the issue is inside the ENET driver, I guess you did NOT add "no_console_suspend" in the cmdline, so when failed, you can NOT see any log, please check the attached log, I can see the failure is in FEC when reusme.

	I also tried using sd rootfs and unplug the enet cable, the suspend/resume is OK without FEC driver. So please add "no_console_suspend" into cmdline and do debug for FEC driver.


Best regards!
Anson Huang


-----Original Message-----
From: Fabio Estevam [mailto:festevam@...il.com] 
Sent: 2014-10-29 7:48 PM
To: Duan Fugang-B38611; Huang Yongcai-B20788
Cc: Li Frank-B20596; Russell King; Shawn Guo; netdev@...r.kernel.org
Subject: Re: suspend/resume broken on 3.18-rc2

On Wed, Oct 29, 2014 at 3:46 AM, fugang.duan@...escale.com <fugang.duan@...escale.com> wrote:

> Hi, Fabio,
>
> I test 3.18.0-rc2, and has some problems:
> - most of time, imx6sx-sdb cannot resume back regardless of nfs or SD rootfs, and power key also cannnot resume back.
> - when do "echo core > /sys/power/pm_test", and then do suspend/resume test, console key can wake up system, but no broken issue found in nfs.

Adding Anson in case he could look into this problem from a power management perspective.

View attachment "318-rc2.TXT" of type "text/plain" (49804 bytes)

Powered by blists - more mailing lists