lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Mon, 10 Nov 2014 08:23:01 +0100
From:	Jiri Pirko <jiri@...nulli.us>
To:	Jamal Hadi Salim <jhs@...atatu.com>
Cc:	netdev@...r.kernel.org, davem@...emloft.net, nhorman@...driver.com,
	andy@...yhouse.net, tgraf@...g.ch, dborkman@...hat.com,
	ogerlitz@...lanox.com, jesse@...ira.com, pshelar@...ira.com,
	azhou@...ira.com, ben@...adent.org.uk, stephen@...workplumber.org,
	jeffrey.t.kirsher@...el.com, vyasevic@...hat.com,
	xiyou.wangcong@...il.com, john.r.fastabend@...el.com,
	edumazet@...gle.com, sfeldma@...il.com, f.fainelli@...il.com,
	roopa@...ulusnetworks.com, linville@...driver.com,
	jasowang@...hat.com, ebiederm@...ssion.com,
	nicolas.dichtel@...nd.com, ryazanov.s.a@...il.com,
	buytenh@...tstofly.org, aviadr@...lanox.com, nbd@...nwrt.org,
	alexei.starovoitov@...il.com, Neil.Jerram@...aswitch.com,
	ronye@...lanox.com, simon.horman@...ronome.com,
	alexander.h.duyck@...hat.com, john.ronciak@...el.com,
	mleitner@...hat.com, shrijeet@...il.com, gospo@...ulusnetworks.com,
	bcrl@...ck.org
Subject: Re: [patch net-next v2 00/10] introduce rocker switch driver with
 hardware accelerated datapath api - phase 1: bridge fdb offload

Mon, Nov 10, 2014 at 04:31:39AM CET, jhs@...atatu.com wrote:
>Jiri,
>
>I am hoping you have considered what Ben Lahaise's, John Fastabend's,
>and Roopa's patches after all those discussions and
>meetings we have had (in which you promised you will merge patches
>in). I am not seeing much of that here or mention of anything of that
>sort.

Hi Jamal.

Yes I looked over their patches. Roopas patche's are about new class of
device which, as I commented in the cover letter, I left out for now and
can be safely added later on.

I went over the Ben's work very carefully as well. The patches are very
rough, mostly rtl-chip specific. But again, my patchset is a base on
which this patches can be build on. I see no issues in that.

>At least please get their sign on - this  is such an important piece of
>new work that you should make sure you get consensus.

Since I did not use their code now, I only put sign off of Scott.

>Otherwise we are back to square one and everyone is going their way with
>their patches;

I do think that we are in sync. I do not see any counter ways. As I
said, their work can be added on to the base made of this patchset.

>
>Ben/Roopa/John - please issue either a signed-off as well
>if you agree with this approach otherwise i am hoping none of these
>patches are merged in.
>
>I will look at the patches and comment.
>
>cheers,
>jamal
>
>On 11/09/14 05:51, Jiri Pirko wrote:
>>Hi all.
>>
>>This patchset is just the first phase of switch and switch-ish device
>>support api in kernel. Note that the api will extend (our complete work
>>can be pulled from https://github.com/jpirko/net-next-rocker).
>>
>>So what this patchset includes:
>>- introduce switchdev api for implementing switch drivers (so far
>>   only linux bridge fdb offload is covered)
>>- introduce rocker switch driver which implements switchdev api
>>
>>As to the discussion if there is need to have specific class of device
>>representing the switch itself, so far we found no need to introduce that.
>>But we are generally ok with the idea and when the time comes and it will
>>be needed, it can be easily introduced without any disturbance.
>>
>>This patchset introduces switch id export through rtnetlink and sysfs,
>>which is similar to what we have for port id in SR-IOV. I will send iproute2
>>patchset for showing the switch id for port netdevs once this is applied.
>>
>>For detailed description, please see individual patches.
>>
>>v1->v2:
>>- addressed all DaveM's comments
>>
>>Jiri Pirko (5):
>>   net: rename netdev_phys_port_id to more generic name
>>   net: introduce generic switch devices support
>>   rtnl: expose physical switch id for particular device
>>   net-sysfs: expose physical switch id for particular device
>>   rocker: introduce rocker switch driver
>>
>>Scott Feldman (5):
>>   bridge: introduce fdb offloading via switchdev
>>   bridge: call netdev_sw_port_stp_update when bridge port STP status
>>     changes
>>   bridge: add API to notify bridge driver of learned FBD on offloaded
>>     device
>>   rocker: implement rocker ofdpa flow table manipulation
>>   rocker: implement L2 bridge offloading
>>
>>  Documentation/networking/switchdev.txt           |   59 +
>>  MAINTAINERS                                      |   14 +
>>  drivers/net/ethernet/Kconfig                     |    1 +
>>  drivers/net/ethernet/Makefile                    |    1 +
>>  drivers/net/ethernet/broadcom/bnx2x/bnx2x_main.c |    2 +-
>>  drivers/net/ethernet/intel/i40e/i40e_main.c      |    2 +-
>>  drivers/net/ethernet/mellanox/mlx4/en_netdev.c   |    2 +-
>>  drivers/net/ethernet/qlogic/qlcnic/qlcnic_main.c |    2 +-
>>  drivers/net/ethernet/rocker/Kconfig              |   27 +
>>  drivers/net/ethernet/rocker/Makefile             |    5 +
>>  drivers/net/ethernet/rocker/rocker.c             | 4182 ++++++++++++++++++++++
>>  drivers/net/ethernet/rocker/rocker.h             |  427 +++
>>  include/linux/if_bridge.h                        |   18 +
>>  include/linux/netdevice.h                        |   48 +-
>>  include/net/switchdev.h                          |   53 +
>>  include/uapi/linux/if_link.h                     |    1 +
>>  net/Kconfig                                      |    1 +
>>  net/Makefile                                     |    3 +
>>  net/bridge/br_fdb.c                              |   94 +-
>>  net/bridge/br_netlink.c                          |    2 +
>>  net/bridge/br_stp.c                              |    4 +
>>  net/bridge/br_stp_if.c                           |    3 +
>>  net/bridge/br_stp_timer.c                        |    2 +
>>  net/core/dev.c                                   |    2 +-
>>  net/core/net-sysfs.c                             |   26 +-
>>  net/core/rtnetlink.c                             |   30 +-
>>  net/switchdev/Kconfig                            |   13 +
>>  net/switchdev/Makefile                           |    5 +
>>  net/switchdev/switchdev.c                        |   93 +
>>  29 files changed, 5104 insertions(+), 18 deletions(-)
>>  create mode 100644 Documentation/networking/switchdev.txt
>>  create mode 100644 drivers/net/ethernet/rocker/Kconfig
>>  create mode 100644 drivers/net/ethernet/rocker/Makefile
>>  create mode 100644 drivers/net/ethernet/rocker/rocker.c
>>  create mode 100644 drivers/net/ethernet/rocker/rocker.h
>>  create mode 100644 include/net/switchdev.h
>>  create mode 100644 net/switchdev/Kconfig
>>  create mode 100644 net/switchdev/Makefile
>>  create mode 100644 net/switchdev/switchdev.c
>>
>
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ