[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20141110074344.GB1850@nanopsycho.orion>
Date: Mon, 10 Nov 2014 08:43:44 +0100
From: Jiri Pirko <jiri@...nulli.us>
To: Jamal Hadi Salim <jhs@...atatu.com>
Cc: netdev@...r.kernel.org, davem@...emloft.net, nhorman@...driver.com,
andy@...yhouse.net, tgraf@...g.ch, dborkman@...hat.com,
ogerlitz@...lanox.com, jesse@...ira.com, pshelar@...ira.com,
azhou@...ira.com, ben@...adent.org.uk, stephen@...workplumber.org,
jeffrey.t.kirsher@...el.com, vyasevic@...hat.com,
xiyou.wangcong@...il.com, john.r.fastabend@...el.com,
edumazet@...gle.com, sfeldma@...il.com, f.fainelli@...il.com,
roopa@...ulusnetworks.com, linville@...driver.com,
jasowang@...hat.com, ebiederm@...ssion.com,
nicolas.dichtel@...nd.com, ryazanov.s.a@...il.com,
buytenh@...tstofly.org, aviadr@...lanox.com, nbd@...nwrt.org,
alexei.starovoitov@...il.com, Neil.Jerram@...aswitch.com,
ronye@...lanox.com, simon.horman@...ronome.com,
alexander.h.duyck@...hat.com, john.ronciak@...el.com,
mleitner@...hat.com, shrijeet@...il.com, gospo@...ulusnetworks.com,
bcrl@...ck.org
Subject: Re: [patch net-next v2 01/10] net: rename netdev_phys_port_id to
more generic name
Mon, Nov 10, 2014 at 04:35:12AM CET, jhs@...atatu.com wrote:
>
>On 11/09/14 05:51, Jiri Pirko wrote:
>>So this can be reused for identification of other "items" as well.
>>
>
>
>
>
>>
>>diff --git a/net/core/net-sysfs.c b/net/core/net-sysfs.c
>>index 9dd0669..55dc4da 100644
>>--- a/net/core/net-sysfs.c
>>+++ b/net/core/net-sysfs.c
>>@@ -387,7 +387,7 @@ static ssize_t phys_port_id_show(struct device *dev,
>> return restart_syscall();
>>
>> if (dev_isalive(netdev)) {
>>- struct netdev_phys_port_id ppid;
>>+ struct netdev_phys_item_id ppid;
>>
>> ret = dev_get_phys_port_id(netdev, &ppid);
>> if (!ret)
>>diff --git a/net/core/rtnetlink.c b/net/core/rtnetlink.c
>>index a688268..1087c6d 100644
>>--- a/net/core/rtnetlink.c
>>+++ b/net/core/rtnetlink.c
>>@@ -868,7 +868,7 @@ static noinline size_t if_nlmsg_size(const struct net_device *dev,
>> + rtnl_port_size(dev, ext_filter_mask) /* IFLA_VF_PORTS + IFLA_PORT_SELF */
>> + rtnl_link_get_size(dev) /* IFLA_LINKINFO */
>> + rtnl_link_get_af_size(dev) /* IFLA_AF_SPEC */
>>- + nla_total_size(MAX_PHYS_PORT_ID_LEN); /* IFLA_PHYS_PORT_ID */
>>+ + nla_total_size(MAX_PHYS_ITEM_ID_LEN); /* IFLA_PHYS_PORT_ID */
>> }
>>
>
>[...]
>> static int rtnl_vf_ports_fill(struct sk_buff *skb, struct net_device *dev)
>>@@ -952,7 +952,7 @@ static int rtnl_port_fill(struct sk_buff *skb, struct net_device *dev,
>> static int rtnl_phys_port_id_fill(struct sk_buff *skb, struct net_device *dev)
>> {
>> int err;
>>- struct netdev_phys_port_id ppid;
>>+ struct netdev_phys_item_id ppid;
>>
>> err = dev_get_phys_port_id(dev, &ppid);
>> if (err) {
>>@@ -1196,7 +1196,7 @@ static const struct nla_policy ifla_policy[IFLA_MAX+1] = {
>> [IFLA_PROMISCUITY] = { .type = NLA_U32 },
>> [IFLA_NUM_TX_QUEUES] = { .type = NLA_U32 },
>> [IFLA_NUM_RX_QUEUES] = { .type = NLA_U32 },
>>- [IFLA_PHYS_PORT_ID] = { .type = NLA_BINARY, .len = MAX_PHYS_PORT_ID_LEN },
>>+ [IFLA_PHYS_PORT_ID] = { .type = NLA_BINARY, .len = MAX_PHYS_ITEM_ID_LEN },
>> [IFLA_CARRIER_CHANGES] = { .type = NLA_U32 }, /* ignored */
>> };
>
>
>wouldnt this just break an existing ABI? You may need to introduce a new
>attribute.
I don't see a reason why this would break kabi:
-#define MAX_PHYS_PORT_ID_LEN 32
+#define MAX_PHYS_ITEM_ID_LEN 32
>
>cheers,
>jamal
>
>
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists