[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <CAGXr9JHUYEuAxC+Ur55n+SxXaP5-kzaMR0hKF6k=g0Nv7XLWoA@mail.gmail.com>
Date: Thu, 26 Mar 2015 10:50:42 -0700
From: Petri Gynther <pgynther@...gle.com>
To: Florian Fainelli <f.fainelli@...il.com>
Cc: netdev <netdev@...r.kernel.org>,
David Miller <davem@...emloft.net>,
Jaedon Shin <jaedon.shin@...il.com>
Subject: Re: [PATCH net-next 4/7] net: bcmgenet: tweak init_umac()
Hi Florian,
On Wed, Mar 25, 2015 at 3:23 PM, Florian Fainelli <f.fainelli@...il.com> wrote:
> On 25/03/15 12:35, Petri Gynther wrote:
>> Use more meaningful variable names int0_enable and int1_enable when
>> enabling bcmgenet interrupts.
>>
>> For Rx default queue interrupts, use:
>> UMAC_IRQ_RXDMA_BDONE | UMAC_IRQ_RXDMA_PDONE
>>
>> For Tx default queue interrupts, use:
>> UMAC_IRQ_TXDMA_BDONE | UMAC_IRQ_TXDMA_PDONE
>
> Can we define a constant for these two, kind of like what I did earlier
> with UMAC_IRQ_RXDMA_MASK and UMAC_IRQ_TXDMA_MASK?
>
> Does not need to happen now, but it could make the code clearer.
>
After this patch set is applied, I'll craft a patch for:
#define UMAC_IRQ_RXDMA_DONE (UMAC_IRQ_RXDMA_BDONE | UMAC_IRQ_RXDMA_PDONE)
#define UMAC_IRQ_TXDMA_DONE (UMAC_IRQ_TXDMA_BDONE | UMAC_IRQ_TXDMA_PDONE)
>>
>> Signed-off-by: Petri Gynther <pgynther@...gle.com>
>
> Reviewed-by: Florian Fainelli <f.fainelli@...il.com>
> --
> Florian
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists