[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20150820.155128.302382371842900422.davem@davemloft.net>
Date: Thu, 20 Aug 2015 15:51:28 -0700 (PDT)
From: David Miller <davem@...emloft.net>
To: izumi.taku@...fujitsu.com
Cc: netdev@...r.kernel.org, platform-driver-x86@...r.kernel.org,
dvhart@...radead.org, rkhan@...hat.com,
alexander.h.duyck@...hat.com, linux-acpi@...r.kernel.org,
joe@...ches.com, sergei.shtylyov@...entembedded.com,
stephen@...workplumber.org, yasu.isimatu@...il.com
Subject: Re: [PATCH v2.2 04/22] fjes: platform_driver's .probe and .remove
routine
From: Taku Izumi <izumi.taku@...fujitsu.com>
Date: Thu, 20 Aug 2015 17:46:08 +0900
> +
> +err_register:
> + fjes_hw_exit(&adapter->hw);
> +err_hw_init:
> +err_sw_init:
> + free_netdev(netdev);
> +err_alloc_netdev:
> + return err;
Having multiple code labels in the same exact spot is suboptimal.
Instead, name the labels such that they describe the first cleanup
action they will perform, instead of the context in which they are
jumped to from.
So "err_hw_exit:", "err_free_netdev", and "err_out:" would be
appropriate.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists