[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20151005.033024.2236659260552514725.davem@davemloft.net>
Date: Mon, 05 Oct 2015 03:30:24 -0700 (PDT)
From: David Miller <davem@...emloft.net>
To: santosh.shilimkar@...cle.com
Cc: netdev@...r.kernel.org, linux-rdma@...r.kernel.org,
linux-kernel@...r.kernel.org, ssantosh@...nel.org
Subject: Re: [PATCH v2 05/14] RDS: defer the over_batch work to send worker
From: Santosh Shilimkar <santosh.shilimkar@...cle.com>
Date: Wed, 30 Sep 2015 13:24:24 -0400
> @@ -423,7 +423,9 @@ over_batch:
> !list_empty(&conn->c_send_queue)) &&
> send_gen == conn->c_send_gen) {
> rds_stats_inc(s_send_lock_queue_raced);
> - goto restart;
> + if (batch_count < 1024)
> + goto restart;
> + queue_delayed_work(rds_wq, &conn->c_send_w, 1);
Sorry, you can't just use a magic number like this.
You have to describe, in detail, exactly how this value was
choosen, derived, and tested to be effeective and in exactly
what environment those tests were done.
You must also use a mnenomic for this value rather than a
raw magic constant.
Thanks.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Powered by blists - more mailing lists