lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date:	Fri, 20 Nov 2015 08:22:07 -0800
From:	Stephen Hemminger <stephen@...workplumber.org>
To:	Oliver Neukum <oliver@...kum.org>
Cc:	netdev@...r.kernel.org, linux-usb@...r.kernel.org
Subject: Fw: [Bug 108201] New: Can connect with Huawei E3131-s2 (Hi-Link) 3G
 modem only after reboot.

Appears to be a cdc_ether driver bug. See Bugzilla for more followup info

Begin forwarded message:

Date: Fri, 20 Nov 2015 11:11:26 +0000
From: "bugzilla-daemon@...zilla.kernel.org" <bugzilla-daemon@...zilla.kernel.org>
To: "shemminger@...ux-foundation.org" <shemminger@...ux-foundation.org>
Subject: [Bug 108201] New: Can connect with Huawei E3131-s2 (Hi-Link) 3G modem only after reboot.


https://bugzilla.kernel.org/show_bug.cgi?id=108201

            Bug ID: 108201
           Summary: Can connect with Huawei E3131-s2 (Hi-Link) 3G modem
                    only after reboot.
           Product: Networking
           Version: 2.5
    Kernel Version: 4.1.12-1-default
          Hardware: x86-64
                OS: Linux
              Tree: Mainline
            Status: NEW
          Severity: normal
          Priority: P1
         Component: Other
          Assignee: shemminger@...ux-foundation.org
          Reporter: cameronpoe@...zta.fm
        Regression: No

When I start (boot) the system from shutdown state I can't connect to Internet
because there is no network connection in pop-up network plasma menu (close to
clock in right bottom of the screen) in new openSUSE Leap 42.1 with KDE 5.

When I shutdown the laptop and start again (boot again) it still doesn't
connect (no connection available), but if I restart (reboot) the system the
connection works (shows in plasma networking pop-up menu).

>From what I can see in journalctl when I boot the laptop for the 1st time the
system recognizes this modem as memory stick and there are errors in
journalctl:

NetworkManager[878]: <warn>  (eth1): failed to find device 4 'eth1' with udev
NetworkManager[878]: <info>  (eth1): new Ethernet device (carrier: OFF, driver:
'cdc_ether', ifindex: 4)
kernel: cdc_ether 3-1:1.0 eth1: register 'cdc_ether' at usb-0000:00:12.2-1, CDC
Ethernet Device, 58:2c:80:13:92:63
kernel: usbcore: registered new interface driver cdc_ether
NetworkManager[878]: <info>  (eth1): device state change: unmanaged ->
unavailable (reason 'managed') [10 20 2]
kernel: cdc_ether 3-1:1.0 eth1: kevent 12 may have been dropped
NetworkManager[878]: <info>  (eth1): link connected
NetworkManager[878]: <info>  (eth1): device state change: unavailable ->
disconnected (reason 'none') [20 30 0]

...but when I reboot the laptop the system recognizes it as modem strait away
and there are no "failed" nor "dropped" messages. I will attach 2 files with
journalctl from the 1st boot and the reboot.

I have always been installing the Huawei E3131-s2 (Hi-Link) from Linux driver
attached in the modem's internal memory and it always worked, but now when I
reinstalled the openSUSE system to newer version 42.1 there was an "failed"
error with runmbbservice so I deactivated it. Anyway, the connection did not
work either.

Another thing - when I unplug the modem and plug it back in it fails again and
the connection vanishes (doesn't show up when I plug modem back) and I have to
reboot the system to be able to connect to the Internet.

I is annoying to always boot the system and reboot in order to connect t the
Internet :( So, can anyone fix this please?

-- 
You are receiving this mail because:
You are the assignee for the bug.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Powered by blists - more mailing lists