lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Wed, 3 Feb 2016 10:24:20 -0800
From:	Alexander Duyck <>
To:	Eric Dumazet <>
Cc:	Hans Westgaard Ry <>,
	"David S. Miller" <>,
	Alexey Kuznetsov <>,
	James Morris <>,
	Hideaki YOSHIFUJI <>,
	Patrick McHardy <>,
	Tom Herbert <>,
	Pablo Neira Ayuso <>,
	Eric Dumazet <>,
	Florian Westphal <>, Jiri Pirko <>,
	Alexander Duyck <>,
	Michal Hocko <>,
	Linus Lüssing <>,
	Hannes Frederic Sowa <>,
	Herbert Xu <>,
	Tejun Heo <>,
	Andrew Morton <>,
	Alexey Kodanev <>,
	Håkon Bugge <>,
	open list <>,
	"open list:NETWORKING [GENERAL]" <>
Subject: Re: [PATCH v3] net:Add sysctl_max_skb_frags

On Wed, Feb 3, 2016 at 9:54 AM, Eric Dumazet <> wrote:
> On Wed, 2016-02-03 at 09:43 -0800, Alexander Duyck wrote:
>> Read the history.  I still say it is best if we don't accept a partial
>> solution.  If we are going to introduce the sysctl as a core item it
>> should function as a core item and not as something that belongs to
>> TCP only.
> But this patch is the base, adding both the core sysctl and its first
> usage.
> Do we really need to split it in 2 patches ? Really ?
> The goal is to use it in all skb providers were it might be a
> performance gain, once they are identified.

That is what I thought.  So why are we trying to sell this as a core
change then.  All I am asking for is the sysctl to be moved and
renamed since based on all of your descriptions this clearly only
impacts TCP.

> Your points were already raised and will be addressed, by either me or
> you. And maybe others.

Please don't sign me up for work I didn't volunteer for.  I already
have enough broken code to try and fix.  I'm pretty sure I need to go
in and fix the gso_max_size code for starters.

If this is only meant to be a performance modification and is only
really targeted at TCP TSO/GRO then all I ask is that we use a name
like tcp_max_gso_frags and relocate the sysctl to the TCP section.
Otherwise if we are actually going to try to scope this out on a wider
level and limit all frags which is what the name implies then the
patch set needs to make a better attempt at covering all cases where
it may apply.

- Alex

Powered by blists - more mailing lists