[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAGXr9JGfQAYEorhmBd9iDidTRNayyjT-3YxAuoYvDEtpV_kKvQ@mail.gmail.com>
Date: Wed, 6 Apr 2016 12:09:15 -0700
From: Petri Gynther <pgynther@...gle.com>
To: David Laight <David.Laight@...lab.com>
Cc: "netdev@...r.kernel.org" <netdev@...r.kernel.org>,
"davem@...emloft.net" <davem@...emloft.net>,
"f.fainelli@...il.com" <f.fainelli@...il.com>,
"jaedon.shin@...il.com" <jaedon.shin@...il.com>
Subject: Re: [PATCH net-next 1/3] net: bcmgenet: cleanup for bcmgenet_xmit()
On Wed, Apr 6, 2016 at 1:57 AM, David Laight <David.Laight@...lab.com> wrote:
> From: Petri Gynther
>> Sent: 05 April 2016 01:10
> ...
>> 2. Readability: Add parentheses around nr_frags + 1.
> ...
>> - if (ring->free_bds <= nr_frags + 1) {
> ...
>> + if (ring->free_bds <= (nr_frags + 1)) {
>
> The extra () are not needed and do not improve readability.
>
> David
>
Not needed from C language point of view, but I personally like it
better that way.
Also, making it consistent with these:
bcmgenet.c:1227: if (ring->free_bds > (MAX_SKB_FRAGS + 1)) {
bcmgenet.c:1523: if (ring->free_bds <= (MAX_SKB_FRAGS + 1))
Powered by blists - more mailing lists