[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <9FB95BB0-0382-41AF-9B1E-5D17D1523F3B@holtmann.org>
Date: Tue, 2 Aug 2016 15:56:28 +0200
From: Marcel Holtmann <marcel@...tmann.org>
To: Baole Ni <baolex.ni@...el.com>
Cc: "Gustavo F. Padovan" <gustavo@...ovan.org>,
Johan Hedberg <johan.hedberg@...il.com>,
"David S. Miller" <davem@...emloft.net>, jiangshanlai@...il.com,
m.chehab@...sung.com,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Marek Szyprowski <m.szyprowski@...sung.com>,
kyungmin.park@...sung.com, k.kozlowski@...sung.com,
"open list:BLUETOOTH DRIVERS" <linux-bluetooth@...r.kernel.org>,
Network Development <netdev@...r.kernel.org>,
open list <linux-kernel@...r.kernel.org>,
chuansheng.liu@...el.com, mhocko@...e.com, koct9i@...il.com,
Andrea Arcangeli <aarcange@...hat.com>, aryabinin@...tuozzo.com
Subject: Re: [PATCH 1088/1285] Replace numeric parameter like 0444 with macro
Hi Baole,
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
>
> Signed-off-by: Chuansheng Liu <chuansheng.liu@...el.com>
> Signed-off-by: Baole Ni <baolex.ni@...el.com>
> ---
> net/bluetooth/l2cap_core.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/net/bluetooth/l2cap_core.c b/net/bluetooth/l2cap_core.c
> index eb4f5f2..1dfb4bc 100644
> --- a/net/bluetooth/l2cap_core.c
> +++ b/net/bluetooth/l2cap_core.c
> @@ -7636,5 +7636,5 @@ void l2cap_exit(void)
> l2cap_cleanup_sockets();
> }
>
> -module_param(disable_ertm, bool, 0644);
> +module_param(disable_ertm, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
> MODULE_PARM_DESC(disable_ertm, "Disable enhanced retransmission mode");
I am not taking any of these patches for the Bluetooth subsystem or its drivers. They are pretty much pointless to me and do not improve readability. I think they actually decrease readability. Every Unix/Linux developers knowns what 0644 (and all its magic cousins) mean.
The only way I would accept any patches to change this is if they would introduce module_param_rw / module_param_ro or something alike. Since I am pretty sure the majority is 644 and 444 here anyway.
Regards
Marcel
Powered by blists - more mailing lists