[<prev] [next>] [day] [month] [year] [list]
Message-Id: <20160802115340.7846-1-baolex.ni@intel.com>
Date: Tue, 2 Aug 2016 19:53:40 +0800
From: Baole Ni <baolex.ni@...el.com>
To: richardcochran@...il.com, benh@...nel.crashing.org,
paulus@...ba.org, mpe@...erman.id.au, dwmw2@...radead.org,
m.chehab@...sung.com, pawel@...iak.com, m.szyprowski@...sung.com,
kyungmin.park@...sung.com, k.kozlowski@...sung.com
Cc: netdev@...r.kernel.org, linux-kernel@...r.kernel.org,
chuansheng.liu@...el.com, baolex.ni@...el.com
Subject: [PATCH 0868/1285] Replace numeric parameter like 0444 with macro
I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.
Signed-off-by: Chuansheng Liu <chuansheng.liu@...el.com>
Signed-off-by: Baole Ni <baolex.ni@...el.com>
---
drivers/ptp/ptp_pch.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/ptp/ptp_pch.c b/drivers/ptp/ptp_pch.c
index 3aa22ae..8bbcdb6 100644
--- a/drivers/ptp/ptp_pch.c
+++ b/drivers/ptp/ptp_pch.c
@@ -727,7 +727,7 @@ module_init(ptp_pch_init);
module_exit(ptp_pch_exit);
module_param_string(station,
- pch_param.station, sizeof(pch_param.station), 0444);
+ pch_param.station, sizeof(pch_param.station), S_IRUSR | S_IRGRP | S_IROTH);
MODULE_PARM_DESC(station,
"IEEE 1588 station address to use - colon separated hex values");
--
2.9.2
Powered by blists - more mailing lists