lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 13 Feb 2017 15:14:49 +0100 (CET)
From:   Andreas Schultz <>
To:     laforge <>
Cc:     pablo <>, netdev <>,
        Lionel Gauthier <>,
        openbsc <>
Subject: Re: [PATCH net-next v2 4/6] gtp: consolidate pdp context
 destruction into helper

----- On Feb 6, 2017, at 2:58 PM, laforge wrote:

> Hi Andreas,
> On Mon, Jan 30, 2017 at 05:37:11PM +0100, Andreas Schultz wrote:
>> Consolidate duplicate code into helper.
> Makes complete sense.
> However:
>> +static void pdp_context_delete(struct pdp_ctx *pctx);
>> +
> why introduce the forward-declaration and then define the function
> further down in the file?  I think in general, it is preferred to put
> helper functions on top, before their first use, so forward declarations
> can be avoided?  Particularly if the helper function doesn't call any
> other functions that are not yet declared at this point.

I wanted to keep functions that work on the data structure close
together. I this case the function the initialized the pdp context
and the delete function for it.


> Please note the above might just be my personal taste, not sure if
> that's a general habit in the kernel networking code these days.
> So with or without the re-ordering:
> Acked-by: Harald Welte <>
> --
> - Harald Welte <> 
> ============================================================================
> "Privacy in residential applications is a desirable marketing option."
>                                                   (ETSI EN 300 175-7 Ch. A6)

Powered by blists - more mailing lists