[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20170516122532.GL1939@nanopsycho.orion>
Date: Tue, 16 May 2017 14:25:32 +0200
From: Jiri Pirko <jiri@...nulli.us>
To: Jamal Hadi Salim <jhs@...atatu.com>
Cc: netdev@...r.kernel.org, davem@...emloft.net,
xiyou.wangcong@...il.com, dsa@...ulusnetworks.com,
edumazet@...gle.com, stephen@...workplumber.org,
daniel@...earbox.net, alexander.h.duyck@...el.com,
simon.horman@...ronome.com, mlxsw@...lanox.com
Subject: Re: [patch net-next v2 04/10] net: sched: replace nprio by a bool to
make the function more readable
Tue, May 16, 2017 at 02:09:25PM CEST, jhs@...atatu.com wrote:
>On 17-05-15 04:38 AM, Jiri Pirko wrote:
>
>> diff --git a/net/sched/cls_api.c b/net/sched/cls_api.c
>> index 88ec1a1..0e49e6e 100644
>> --- a/net/sched/cls_api.c
>> +++ b/net/sched/cls_api.c
>> @@ -271,7 +271,7 @@ static int tc_ctl_tfilter(struct sk_buff *skb, struct nlmsghdr *n,
>> struct tcmsg *t;
>> u32 protocol;
>> u32 prio;
>> - u32 nprio;
>> + bool prio_allocate;
>
>prio_allocated? (past tense seems more sensible)
No, it actually tell if the prio should be allocated:
if (prio_allocate)
prio = tcf_auto_prio(tcf_chain_tp_prev(&chain_info));
I believe it is accurate.
Powered by blists - more mailing lists