lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 1 Mar 2018 16:03:29 -0300
From:   Marcelo Ricardo Leitner <marcelo.leitner@...il.com>
To:     Roman Mashak <mrv@...atatu.com>
Cc:     davem@...emloft.net, netdev@...r.kernel.org, jhs@...atatu.com,
        jiri@...nulli.us, xiyou.wangcong@...il.com
Subject: Re: [PATCH 4/5] net sched actions: implement get_fill_size routine
 in act_gact

On Thu, Mar 01, 2018 at 01:45:30PM -0500, Roman Mashak wrote:
> Signed-off-by: Roman Mashak <mrv@...atatu.com>
> ---
>  net/sched/act_gact.c | 17 +++++++++++++++++
>  1 file changed, 17 insertions(+)
> 
> diff --git a/net/sched/act_gact.c b/net/sched/act_gact.c
> index 7456325..ee775ac 100644
> --- a/net/sched/act_gact.c
> +++ b/net/sched/act_gact.c
> @@ -217,6 +217,22 @@ static int tcf_gact_search(struct net *net, struct tc_action **a, u32 index,
>  	return tcf_idr_search(tn, a, index);
>  }
>  
> +static size_t tcf_gact_get_fill_size(const struct tc_action *act)
> +{
> +#ifdef CONFIG_GACT_PROB
> +	struct tcf_gact *gact = to_gact(act);
> +	int prob_len = 0;
> +
> +	if (gact->tcfg_ptype)
> +		prob_len = nla_total_size(sizeof(struct tc_gact_p));
> +#endif
> +	return	nla_total_size(sizeof(struct tc_gact)) /* TCA_GACT_PARMS */
> +#ifdef CONFIG_GACT_PROB
> +		+ prob_len /* TCA_GACT_PROB */
> +#endif
> +		;
> +}

This is quite bad to the eye. What about:

static size_t tcf_gact_get_fill_size(const struct tc_action *act)
{
	size_t sz = nla_total_size(sizeof(struct tc_gact)); /* TCA_GACT_PARMS */

#ifdef CONFIG_GACT_PROB
	if (to_gact(act)->tcfg_ptype)
		sz += nla_total_size(sizeof(struct tc_gact_p)); /* TCA_GACT_PROB */
#endif

	return sz;
}

Should be the same, bug easier to read.

> +
>  static struct tc_action_ops act_gact_ops = {
>  	.kind		=	"gact",
>  	.type		=	TCA_ACT_GACT,
> @@ -227,6 +243,7 @@ static struct tc_action_ops act_gact_ops = {
>  	.init		=	tcf_gact_init,
>  	.walk		=	tcf_gact_walker,
>  	.lookup		=	tcf_gact_search,
> +	.get_fill_size	=	tcf_gact_get_fill_size,
>  	.size		=	sizeof(struct tcf_gact),
>  };
>  
> -- 
> 2.7.4
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ