[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <1540470417-14803-3-git-send-email-john.hurley@netronome.com>
Date: Thu, 25 Oct 2018 13:26:51 +0100
From: John Hurley <john.hurley@...ronome.com>
To: netdev@...r.kernel.org, oss-drivers@...ronome.com,
jiri@...nulli.us, gerlitz.or@...il.com, ozsh@...lanox.com,
jakub.kicinski@...ronome.com, simon.horman@...ronome.com,
avivh@...lanox.com
Cc: John Hurley <john.hurley@...ronome.com>
Subject: [RFC net-next v2 2/8] net: add netif_is_geneve()
Add a helper function to determine if the type of a netdev is geneve based
on its rtnl_link_ops. This allows drivers that may wish to ofload tunnels
to check the underlying type of the device.
A recent patch added a similar helper to vxlan.h
Signed-off-by: John Hurley <john.hurley@...ronome.com>
Reviewed-by: Jakub Kicinski <jakub.kicinski@...ronome.com>
---
include/net/geneve.h | 6 ++++++
1 file changed, 6 insertions(+)
diff --git a/include/net/geneve.h b/include/net/geneve.h
index a7600ed..fc6a7e0 100644
--- a/include/net/geneve.h
+++ b/include/net/geneve.h
@@ -60,6 +60,12 @@ struct genevehdr {
struct geneve_opt options[];
};
+static inline bool netif_is_geneve(const struct net_device *dev)
+{
+ return dev->rtnl_link_ops &&
+ !strcmp(dev->rtnl_link_ops->kind, "geneve");
+}
+
#ifdef CONFIG_INET
struct net_device *geneve_dev_create_fb(struct net *net, const char *name,
u8 name_assign_type, u16 dst_port);
--
2.7.4
Powered by blists - more mailing lists