[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20190322191255.7629-1-saeedm@mellanox.com>
Date: Fri, 22 Mar 2019 12:12:41 -0700
From: Saeed Mahameed <saeedm@...lanox.com>
To: "David S. Miller" <davem@...emloft.net>
Cc: netdev@...r.kernel.org, Saeed Mahameed <saeedm@...lanox.com>
Subject: [pull request][net-next V3 00/14] Mellanox, mlx5 updates 2019-03-20
Hi Dave,
This series includes mlx5 updates.
For more information please see tag log below.
Please pull and let me know if there is any problem.
v1->v2:
Remove NFP specific vxlan/geneve port #defines based upon Jakub's feedback.
v2->v3:
Drop Roi's Eswitch fix patch, as we want it submitted to net branch.
Thanks,
Saeed.
---
The following changes since commit 3b0f31f2b8c9fb348e4530b88f6b64f9621f83d6:
genetlink: make policy common to family (2019-03-22 10:38:23 -0400)
are available in the Git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/saeed/linux.git tags/mlx5-updates-2019-03-20
for you to fetch changes up to 76b496b1bd79bcd669cd7411e80e09512dc6707f:
net/mlx5e: Replace TC VLAN pop and push actions with VLAN modify (2019-03-22 12:09:32 -0700)
----------------------------------------------------------------
mlx5-updates-2019-03-20
This series includes updates to mlx5 driver,
1) Compiler warnings cleanup from Saeed Mahameed
2) Parav Pandit simplifies sriov enable/disables
3) Gustavo A. R. Silva, Removes a redundant assignment
4) Moshe Shemesh, Adds Geneve tunnel stateless offload support
5) Eli Britstein, Adds the Support for VLAN modify action and
Replaces TC VLAN pop and push actions with VLAN modify
Note: This series includes two simple non-mlx5 patches,
1) Declare IANA_VXLAN_UDP_PORT definition in include/net/vxlan.h,
and use it in some drivers.
2) Declare GENEVE_UDP_PORT definition in include/net/geneve.h,
and use it in mlx5 and nfp drivers.
----------------------------------------------------------------
Eli Britstein (3):
net/mlx5e: Add VLAN ID rewrite fields
net/mlx5e: Support VLAN modify action
net/mlx5e: Replace TC VLAN pop and push actions with VLAN modify
Gustavo A. R. Silva (1):
net/mlx5e: Remove redundant assignment
Moshe Shemesh (4):
net: Move the definition of the default Geneve udp port to public header file
net/mlx5e: Take SW parser code to a separate function
net/mlx5e: TX, Add geneve tunnel stateless offload support
net: Add IANA_VXLAN_UDP_PORT definition to vxlan header file
Parav Pandit (3):
net/mlx5: Simplify sriov enable/disable flow
net/mlx5: Rename total_vfs to total_vports
net/mlx5: Simplify mlx5_sriov_is_enabled() by using pci core API
Saeed Mahameed (3):
net/mlx5: Fix compilation warning in eq.c
net/mlx5e: Fix port buffer function documentation format
net/mlx5e: Fix compilation warning in en_tc.c
drivers/net/ethernet/hisilicon/hns3/hns3_enet.c | 4 +-
drivers/net/ethernet/mellanox/mlx5/core/en.h | 47 ++++++++++++++++
.../ethernet/mellanox/mlx5/core/en/port_buffer.c | 30 +++++-----
.../mellanox/mlx5/core/en_accel/en_accel.h | 51 +++++++++++++++++
.../mellanox/mlx5/core/en_accel/ipsec_rxtx.c | 36 ++++--------
drivers/net/ethernet/mellanox/mlx5/core/en_main.c | 18 +++++-
drivers/net/ethernet/mellanox/mlx5/core/en_tc.c | 65 +++++++++++++++++++++-
drivers/net/ethernet/mellanox/mlx5/core/en_tx.c | 5 ++
drivers/net/ethernet/mellanox/mlx5/core/eq.c | 6 +-
drivers/net/ethernet/mellanox/mlx5/core/eswitch.h | 3 +
.../ethernet/mellanox/mlx5/core/eswitch_offloads.c | 6 +-
.../net/ethernet/mellanox/mlx5/core/lib/port_tun.c | 6 +-
.../net/ethernet/mellanox/mlx5/core/lib/vxlan.c | 5 +-
.../net/ethernet/mellanox/mlx5/core/mlx5_core.h | 6 +-
drivers/net/ethernet/mellanox/mlx5/core/sriov.c | 51 +++--------------
drivers/net/ethernet/netronome/nfp/flower/action.c | 4 +-
drivers/net/ethernet/netronome/nfp/flower/main.h | 3 -
.../net/ethernet/netronome/nfp/flower/offload.c | 4 +-
drivers/net/geneve.c | 2 -
include/linux/mlx5/mlx5_ifc.h | 1 +
include/net/geneve.h | 2 +
include/net/vxlan.h | 2 +
22 files changed, 243 insertions(+), 114 deletions(-)
Powered by blists - more mailing lists