[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <1a78da3c526ef6e631cadd39c596aeabbcb27ea1.camel@redhat.com>
Date: Tue, 27 Aug 2019 12:15:19 +0200
From: Davide Caratti <dcaratti@...hat.com>
To: Stefano Brivio <sbrivio@...hat.com>
Cc: Cong Wang <xiyou.wangcong@...il.com>,
Jamal Hadi Salim <jhs@...atatu.com>,
Jiri Pirko <jiri@...nulli.us>,
"David S. Miller" <davem@...emloft.net>, netdev@...r.kernel.org,
Paolo Abeni <pabeni@...hat.com>, Li Shuang <shuali@...hat.com>
Subject: Re: [PATCH net] net/sched: pfifo_fast: fix wrong dereference when
qdisc is reset
hello Stefano,
thanks for looking at this.
On Tue, 2019-08-27 at 11:50 +0200, Stefano Brivio wrote:
> On Tue, 27 Aug 2019 01:15:16 +0200
> Davide Caratti <dcaratti@...hat.com> wrote:
[...]
> @@ -688,12 +688,14 @@ static void pfifo_fast_reset(struct Qdisc *qdisc)
> > kfree_skb(skb);
> > }
> >
> > - for_each_possible_cpu(i) {
> > - struct gnet_stats_queue *q = per_cpu_ptr(qdisc->cpu_qstats, i);
> > + if (qdisc_is_percpu_stats(qdisc))
>
> This needs curly brackets, as the block has multiple lines (for coding
> style only).
If I well read Documentation/process/coding-style.rst, at the end of
section 3), this rule should apply to loops. But I'm fine with the curly
brace here, if checkpatch doesn't say anything.
I will add it in v2.
> > + for_each_possible_cpu(i) {
> > + struct gnet_stats_queue *q =
> > + per_cpu_ptr(qdisc->cpu_qstats, i);
>
> And you could split declaration and assignment here, it takes two lines
> anyway and becomes more readable.
ok, I will do that in v2.
thanks!
--
davide
Powered by blists - more mailing lists