[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20191024060657.GA2233@nanopsycho.orion>
Date: Thu, 24 Oct 2019 08:06:57 +0200
From: Jiri Pirko <jiri@...nulli.us>
To: David Ahern <dsahern@...il.com>
Cc: netdev@...r.kernel.org, davem@...emloft.net,
jakub.kicinski@...ronome.com, andrew@...n.ch, mlxsw@...lanox.com
Subject: Re: [patch net-next v3 3/3] devlink: add format requirement for
devlink object names
Thu, Oct 24, 2019 at 12:16:27AM CEST, dsahern@...il.com wrote:
>On 10/21/19 11:59 PM, Jiri Pirko wrote:
>> Mon, Oct 21, 2019 at 06:11:33PM CEST, dsahern@...il.com wrote:
>>> On 10/21/19 9:56 AM, Jiri Pirko wrote:
>>>>
>>>> I forgot to update the desc. Uppercase chars are now allowed as Andrew
>>>> requested. Regarding dash, it could be allowed of course. But why isn't
>>>> "_" enough. I mean, I think it would be good to maintain allowed chars
>>>> within a limit.
>>>
>>> That's a personal style question. Is "fib-rules" less readable than
>>> "fib_rules"? Why put such limitations in place if there is no
>>> justifiable reason?
>>
>> You mean any limitation?
>>
>
>I mean why are you pushing a patch to limit what characters can be used
>in names, and why are you deciding '-' is not ok but '_' is?
It is kind of randrom. I just wanted to have some limitations so all
things (params, ...) would look alike for all drivers. That's it.
>
>It just seems so random and not driven by some real limitation (e.g.,
>entries in a filesystem).o
Nothing like that.
Powered by blists - more mailing lists