[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAMzD94SCUQTi=O694HN3Muh=F-NT81_C4kBnzyBu0pfoNi87DQ@mail.gmail.com>
Date: Thu, 21 Nov 2019 13:14:31 -0800
From: Brian Vazquez <brianvv@...gle.com>
To: Yonghong Song <yhs@...com>
Cc: Brian Vazquez <brianvv.kernel@...il.com>,
Alexei Starovoitov <ast@...nel.org>,
Daniel Borkmann <daniel@...earbox.net>,
"David S . Miller" <davem@...emloft.net>,
Stanislav Fomichev <sdf@...gle.com>,
Petar Penkov <ppenkov@...gle.com>,
Willem de Bruijn <willemb@...gle.com>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"netdev@...r.kernel.org" <netdev@...r.kernel.org>,
"bpf@...r.kernel.org" <bpf@...r.kernel.org>
Subject: Re: [PATCH v2 bpf-next 9/9] selftests/bpf: add batch ops testing to
array bpf map
Thanks for reviewing it!
On Thu, Nov 21, 2019 at 10:43 AM Yonghong Song <yhs@...com> wrote:
>
>
>
> On 11/19/19 11:30 AM, Brian Vazquez wrote:
> > Tested bpf_map_lookup_batch() and bpf_map_update_batch()
> > functionality.
> >
> > $ ./test_maps
> > ...
> > test_map_lookup_and_delete_batch_array:PASS
> > ...
>
> The test is for lookup_batch() and update_batch()
> and the test name and func name is lookup_and_delete_batch(),
> probably rename is to lookup_and_update_batch_array()?
>
Yes, you are right, I will change the name for next version.
> It would be good if generic lookup_and_delete_batch()
> and delete_patch() can be tested as well.
> Maybe tried to use prog_array?
I did test generic_lookup_and_delete_batch with hmap and it worked
fine because I didn't have concurrent deletions.
But yes I will add tests for generic delete and lookup_and_delete,
maybe for the trie map (prog_array doesn't support lookup ang hence
lookup_and_delete won't apply there)?
>
> >
> > Signed-off-by: Brian Vazquez <brianvv@...gle.com>
> > Signed-off-by: Yonghong Song <yhs@...com>
> > ---
> > .../map_lookup_and_delete_batch_array.c | 119 ++++++++++++++++++
> > 1 file changed, 119 insertions(+)
> > create mode 100644 tools/testing/selftests/bpf/map_tests/map_lookup_and_delete_batch_array.c
> >
> > diff --git a/tools/testing/selftests/bpf/map_tests/map_lookup_and_delete_batch_array.c b/tools/testing/selftests/bpf/map_tests/map_lookup_and_delete_batch_array.c
> > new file mode 100644
> > index 0000000000000..cbec72ad38609
> > --- /dev/null
> > +++ b/tools/testing/selftests/bpf/map_tests/map_lookup_and_delete_batch_array.c
> > @@ -0,0 +1,119 @@
> > +// SPDX-License-Identifier: GPL-2.0
> > +
> > +#include <stdio.h>
> > +#include <errno.h>
> > +#include <string.h>
> > +
> > +#include <bpf/bpf.h>
> > +#include <bpf/libbpf.h>
> > +
> > +#include <test_maps.h>
> > +
> > +static void map_batch_update(int map_fd, __u32 max_entries, int *keys,
> > + int *values)
> > +{
> > + int i, err;
> > +
> > + for (i = 0; i < max_entries; i++) {
> > + keys[i] = i;
> > + values[i] = i + 1;
> > + }
> > +
> > + err = bpf_map_update_batch(map_fd, keys, values, &max_entries, 0, 0);
> > + CHECK(err, "bpf_map_update_batch()", "error:%s\n", strerror(errno));
> > +}
> > +
> > +static void map_batch_verify(int *visited, __u32 max_entries,
> > + int *keys, int *values)
> > +{
> > + int i;
> > +
> > + memset(visited, 0, max_entries * sizeof(*visited));
> > + for (i = 0; i < max_entries; i++) {
> > + CHECK(keys[i] + 1 != values[i], "key/value checking",
> > + "error: i %d key %d value %d\n", i, keys[i], values[i]);
> > + visited[i] = 1;
> > + }
> > + for (i = 0; i < max_entries; i++) {
> > + CHECK(visited[i] != 1, "visited checking",
> > + "error: keys array at index %d missing\n", i);
> > + }
> > +}
> > +
> > +void test_map_lookup_and_delete_batch_array(void)
> > +{
> > + struct bpf_create_map_attr xattr = {
> > + .name = "array_map",
> > + .map_type = BPF_MAP_TYPE_ARRAY,
> > + .key_size = sizeof(int),
> > + .value_size = sizeof(int),
> > + };
> > + int map_fd, *keys, *values, *visited;
> > + __u32 count, total, total_success;
> > + const __u32 max_entries = 10;
> > + int err, i, step;
> > + bool nospace_err;
> > + __u64 batch = 0;
> > +
> > + xattr.max_entries = max_entries;
> > + map_fd = bpf_create_map_xattr(&xattr);
> > + CHECK(map_fd == -1,
> > + "bpf_create_map_xattr()", "error:%s\n", strerror(errno));
> > +
> > + keys = malloc(max_entries * sizeof(int));
> > + values = malloc(max_entries * sizeof(int));
> > + visited = malloc(max_entries * sizeof(int));
> > + CHECK(!keys || !values || !visited, "malloc()", "error:%s\n",
> > + strerror(errno));
> > +
> > + /* populate elements to the map */
> > + map_batch_update(map_fd, max_entries, keys, values);
> > +
> > + /* test 1: lookup in a loop with various steps. */
> > + total_success = 0;
> > + for (step = 1; step < max_entries; step++) {
> > + map_batch_update(map_fd, max_entries, keys, values);
> > + memset(keys, 0, max_entries * sizeof(*keys));
> > + memset(values, 0, max_entries * sizeof(*values));
> > + batch = 0;
> > + total = 0;
> > + i = 0;
> > + /* iteratively lookup/delete elements with 'step'
> > + * elements each.
> > + */
> > + count = step;
> > + nospace_err = false;
> > + while (true) {
> > + err = bpf_map_lookup_batch(map_fd,
> > + total ? &batch : NULL, &batch,
> > + keys + total,
> > + values + total,
> > + &count, 0, 0);
> > +
> > + CHECK((err && errno != ENOENT), "lookup with steps",
> > + "error: %s\n", strerror(errno));
> > +
> > + total += count;
> > +
> > + if (err)
> > + break;
> > +
> > + i++;
> > + }
> > +
> > + if (nospace_err == true)
> > + continue;
> > +
> > + CHECK(total != max_entries, "lookup with steps",
> > + "total = %u, max_entries = %u\n", total, max_entries);
> > +
> > + map_batch_verify(visited, max_entries, keys, values);
> > +
> > + total_success++;
> > + }
> > +
> > + CHECK(total_success == 0, "check total_success",
> > + "unexpected failure\n");
> > +
> > + printf("%s:PASS\n", __func__);
> > +}
> >
Powered by blists - more mailing lists