[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CALWDO_U5Cnt3_Ss2QQNhtuKS_8qq7oyNH4d97J68pmbmQMe=3w@mail.gmail.com>
Date: Tue, 24 Mar 2020 11:10:52 -0400
From: Alain Michaud <alainmichaud@...gle.com>
To: Joe Perches <joe@...ches.com>
Cc: Marcel Holtmann <marcel@...tmann.org>,
Miao-chen Chou <mcchou@...omium.org>,
Bluetooth Kernel Mailing List
<linux-bluetooth@...r.kernel.org>,
Luiz Augusto von Dentz <luiz.von.dentz@...el.com>,
Alain Michaud <alainm@...omium.org>,
"David S. Miller" <davem@...emloft.net>,
Jakub Kicinski <kuba@...nel.org>,
Johan Hedberg <johan.hedberg@...il.com>,
LKML <linux-kernel@...r.kernel.org>,
netdev <netdev@...r.kernel.org>
Subject: Re: [PATCH v1 1/2] Bluetooth: btusb: Indicate Microsoft vendor
extension for Intel 9460/9560 and 9160/9260
On Mon, Mar 23, 2020 at 4:11 PM Joe Perches <joe@...ches.com> wrote:
>
> On Mon, 2020-03-23 at 19:48 +0100, Marcel Holtmann wrote:
> > Hi Joe,
>
> Hello Marcel.
>
> > > > > This adds a bit mask of driver_info for Microsoft vendor extension and
> > > > > indicates the support for Intel 9460/9560 and 9160/9260. See
> > > > > https://docs.microsoft.com/en-us/windows-hardware/drivers/bluetooth/
> > > > > microsoft-defined-bluetooth-hci-commands-and-events for more information
> > > > > about the extension. This was verified with Intel ThunderPeak BT controller
> > > > > where msft_vnd_ext_opcode is 0xFC1E.
> > > []
> > > > > diff --git a/include/net/bluetooth/hci_core.h b/include/net/bluetooth/hci_core.h
> > > []
> > > > > @@ -315,6 +315,10 @@ struct hci_dev {
> > > > > __u8 ssp_debug_mode;
> > > > > __u8 hw_error_code;
> > > > > __u32 clock;
> > > > > + __u16 msft_vnd_ext_opcode;
> > > > > + __u64 msft_vnd_ext_features;
> > > > > + __u8 msft_vnd_ext_evt_prefix_len;
> > > > > + void *msft_vnd_ext_evt_prefix;
> > >
> > > msft is just another vendor.
> > >
> > > If there are to be vendor extensions, this should
> > > likely use a blank line above and below and not
> > > be prefixed with msft_
> >
> > there are other vendors, but all of them are different. So this needs to be prefixed with msft_ actually. But I agree that having empty lines above and below makes it more readable.
>
> So struct hci_dev should become a clutter
> of random vendor extensions?
>
> Perhaps there should instead be something like
> an array of char at the end of the struct and
> various vendor specific extensions could be
> overlaid on that array or just add a void *
> to whatever info that vendors require.
I don't particularly like trailing buffers, but I agree we could
possibly organize this a little better by with a struct. something
like:
struct msft_vnd_ext {
bool supported; // <-- Clearly calls out if the
extension is supported.
__u16 msft_vnd_ext_opcode; // <-- Note that this also
needs to be provided by the driver. I don't recommend we have this
read from the hardware since we just cause an extra redirection that
isn't necessary. Ideally, this should come from the usb_table const.
__u64 msft_vnd_ext_features;
__u8 msft_vnd_ext_evt_prefix_len;
void *msft_vnd_ext_evt_prefix;
};
And then simply add the struct msft_vnd_ext (and any others) to hci_dev.
>
>
>
Powered by blists - more mailing lists