[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <9DD61F30A802C4429A01CA4200E302A7DCD485B7@fmsmsx124.amr.corp.intel.com>
Date: Tue, 21 Apr 2020 00:27:28 +0000
From: "Saleem, Shiraz" <shiraz.saleem@...el.com>
To: Leon Romanovsky <leon@...nel.org>,
"Kirsher, Jeffrey T" <jeffrey.t.kirsher@...el.com>
CC: "gregkh@...uxfoundation.org" <gregkh@...uxfoundation.org>,
"jgg@...pe.ca" <jgg@...pe.ca>,
"Ismail, Mustafa" <mustafa.ismail@...el.com>,
"netdev@...r.kernel.org" <netdev@...r.kernel.org>,
"linux-rdma@...r.kernel.org" <linux-rdma@...r.kernel.org>,
"nhorman@...hat.com" <nhorman@...hat.com>,
"sassmann@...hat.com" <sassmann@...hat.com>
Subject: RE: [RFC PATCH v5 12/16] RDMA/irdma: Add miscellaneous utility
definitions
> Subject: Re: [RFC PATCH v5 12/16] RDMA/irdma: Add miscellaneous utility
> definitions
>
> On Fri, Apr 17, 2020 at 10:12:47AM -0700, Jeff Kirsher wrote:
> > From: Mustafa Ismail <mustafa.ismail@...el.com>
> >
> > Add miscellaneous utility functions and headers.
> >
> > Signed-off-by: Mustafa Ismail <mustafa.ismail@...el.com>
> > Signed-off-by: Shiraz Saleem <shiraz.saleem@...el.com>
> > ---
> > drivers/infiniband/hw/irdma/osdep.h | 105 ++
> > drivers/infiniband/hw/irdma/protos.h | 93 +
> > drivers/infiniband/hw/irdma/status.h | 69 +
> > drivers/infiniband/hw/irdma/utils.c | 2445
> > ++++++++++++++++++++++++++
> > 4 files changed, 2712 insertions(+)
> > create mode 100644 drivers/infiniband/hw/irdma/osdep.h
> > create mode 100644 drivers/infiniband/hw/irdma/protos.h
> > create mode 100644 drivers/infiniband/hw/irdma/status.h
> > create mode 100644 drivers/infiniband/hw/irdma/utils.c
> >
> > diff --git a/drivers/infiniband/hw/irdma/osdep.h
> > b/drivers/infiniband/hw/irdma/osdep.h
> > new file mode 100644
> > index 000000000000..23ddfb8e9568
> > --- /dev/null
> > +++ b/drivers/infiniband/hw/irdma/osdep.h
> > @@ -0,0 +1,105 @@
> > +/* SPDX-License-Identifier: GPL-2.0 or Linux-OpenIB */
> > +/* Copyright (c) 2015 - 2019 Intel Corporation */ #ifndef
> > +IRDMA_OSDEP_H #define IRDMA_OSDEP_H
> > +
> > +#include <linux/version.h>
>
> Why is that?
Not needed. Thanks!
>
> > +#define irdma_debug_buf(dev, prefix, desc, buf, size) \
> > + print_hex_dump_debug(prefix ": " desc " ", \
> > + DUMP_PREFIX_OFFSET, \
> > + 16, 8, buf, size, false)
> > +
>
> I think that it can be beneficial to be as ibdev_print_buf().
Macro itself looks a little weird since dev is not used and needs to be fixed.
I wonder why there isn't a struct device ver. of this print buf
to start with.
[...]
> > + IRDMA_ERR_BAD_STAG = -66,
> > + IRDMA_ERR_CQ_COMPL_ERROR = -67,
> > + IRDMA_ERR_Q_DESTROYED = -68,
> > + IRDMA_ERR_INVALID_FEAT_CNT = -69,
> > + IRDMA_ERR_REG_CQ_FULL = -70,
> > + IRDMA_ERR_VF_MSG_ERROR = -71,
> > +};
>
> Please don't do vertical space alignment in all the places
vertically aligning groups of defines that are related or enum constants
look more readable.
+ IRDMA_ERR_BAD_STAG = -66,
+ IRDMA_ERR_CQ_COMPL_ERROR = -67,
+ IRDMA_ERR_Q_DESTROYED = -68,
+ IRDMA_ERR_INVALID_FEAT_CNT = -69,
+ IRDMA_ERR_REG_CQ_FULL = -70,
+ IRDMA_ERR_VF_MSG_ERROR = -71,
This looks less readable IMHO.
>
> > +#endif /* IRDMA_STATUS_H */
> > diff --git a/drivers/infiniband/hw/irdma/utils.c
> > b/drivers/infiniband/hw/irdma/utils.c
> > new file mode 100644
> > index 000000000000..be46d672afc5
> > --- /dev/null
> > +++ b/drivers/infiniband/hw/irdma/utils.c
> > @@ -0,0 +1,2445 @@
> > +// SPDX-License-Identifier: GPL-2.0 or Linux-OpenIB
> > +/* Copyright (c) 2015 - 2019 Intel Corporation */ #include
> > +<linux/mii.h> #include <linux/in.h> #include <linux/init.h> #include
> > +<asm/irq.h> #include <asm/byteorder.h> #include <net/neighbour.h>
> > +#include "main.h"
> > +
> > +/**
> > + * irdma_arp_table -manage arp table
> > + * @rf: RDMA PCI function
> > + * @ip_addr: ip address for device
> > + * @ipv4: IPv4 flag
> > + * @mac_addr: mac address ptr
> > + * @action: modify, delete or add
> > + */
> > +int irdma_arp_table(struct irdma_pci_f *rf, u32 *ip_addr, bool ipv4,
> > + u8 *mac_addr, u32 action)
>
> ARP table in the RDMA driver looks strange, I see that it is legacy from i40iw, but
> wonder if it is the right thing to do the same for the new driver.
>
See response in Patch #1.
Powered by blists - more mailing lists