lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 1 May 2020 14:32:32 +0200
From:   Jesper Dangaard Brouer <brouer@...hat.com>
To:     Tariq Toukan <tariqt@...lanox.com>
Cc:     sameehj@...zon.com, Saeed Mahameed <saeedm@...lanox.com>,
        netdev@...r.kernel.org, bpf@...r.kernel.org, zorik@...zon.com,
        akiyano@...zon.com, gtzalik@...zon.com,
        Toke Høiland-Jørgensen 
        <toke@...hat.com>, Daniel Borkmann <borkmann@...earbox.net>,
        Alexei Starovoitov <alexei.starovoitov@...il.com>,
        John Fastabend <john.fastabend@...il.com>,
        Alexander Duyck <alexander.duyck@...il.com>,
        Jeff Kirsher <jeffrey.t.kirsher@...el.com>,
        David Ahern <dsahern@...il.com>,
        Willem de Bruijn <willemdebruijn.kernel@...il.com>,
        Ilias Apalodimas <ilias.apalodimas@...aro.org>,
        Lorenzo Bianconi <lorenzo@...nel.org>,
        steffen.klassert@...unet.com, brouer@...hat.com
Subject: Re: [PATCH net-next v2 28/33] mlx5: rx queue setup time determine
 frame_sz for XDP

On Thu, 30 Apr 2020 20:12:11 +0300
Tariq Toukan <tariqt@...lanox.com> wrote:

> >> diff --git a/drivers/net/ethernet/mellanox/mlx5/core/en.h 
> >> b/drivers/net/ethernet/mellanox/mlx5/core/en.h
> >> index 23701c0e36ec..ba6a0ee297c6 100644
> >> --- a/drivers/net/ethernet/mellanox/mlx5/core/en.h
> >> +++ b/drivers/net/ethernet/mellanox/mlx5/core/en.h
> >> @@ -652,6 +652,7 @@ struct mlx5e_rq {
> >>       struct {
> >>           u16            umem_headroom;
> >>           u16            headroom;
> >> +        u32            first_frame_sz;  
> 
> I also think that a better name would be: frame0_sz, or frag0_sz.

You do realize that the name "first_frame_sz" was your suggestion last
time... Now you give me two options, can please select one of them so I
can update the patch for a V3 with that?

-- 
Best regards,
  Jesper Dangaard Brouer
  MSc.CS, Principal Kernel Engineer at Red Hat
  LinkedIn: http://www.linkedin.com/in/brouer

Powered by blists - more mailing lists