lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 22 Sep 2020 15:19:23 -0700
From:   Jay Vosburgh <>
To:     Jarod Wilson <>
cc:, Veaceslav Falico <>,
        Andy Gospodarek <>,
        "David S. Miller" <>,
        Jakub Kicinski <>,
        Thomas Davis <>,
Subject: Re: [PATCH net-next 0/5] bonding: rename bond components

Jarod Wilson <> wrote:

>The bonding driver's use of master and slave, while largely understood
>in technical circles, poses a barrier for inclusion to some potential
>members of the development and user community, due to the historical
>context of masters and slaves, particularly in the United States. This
>is a first full pass at replacing those phrases with more socially
>inclusive ones, opting for aggregator to replace master and link to
>replace slave, as the bonding driver itself is a link aggregation

	First, I think there should be some direction from the kernel
development leadership as to whether or not this type of large-scale
search and replace of socially sensitive terms of art or other
terminology is a task that should be undertaken, given the noted issues
it will cause in stable release maintenance going forwards.

	Second, on the merits of the proposed changes (presuming for the
moment that this goes forward), I would prefer different nomenclature
that does not reuse existing names for different purposes, i.e., "link"
and "aggregator."

	Both of those have specific meanings in the current code, and
old kernels will retain that meaning.  Changing them to have new
meanings going forward will lead to confusion, in my opinion for no good
reason, as there are other names suited that do not conflict.

	For example, instead of "master" call everything a "bond," which
matches common usage in discussion.  Changing "master" to "aggregator,"
the replacement results in cumbersome descriptions like "the
aggregator's active aggregator" in the context of LACP.

	A replacement term for "slave" is trickier; my first choice
would be "port," but that may make more churn from a code change point
of view, although struct slave could become struct bond_port, and leave
the existing struct port for its current LACP use.

>There are a few problems with this change. First up, "link" is used for
>link state already in the bonding driver, so the first step here is to
>rename link to link_state. Second, aggregator is already used in the
>802.3ad code, but I feel the usage is actually consistent with referring
>to the bonding aggregation virtual device as the aggregator. Third, we
>have the issue of not wanting to break any existing userspace, which I
>believe this patchset accomplishes, while also adding alternative
>interfaces using new terminology, and a Kconfig option that will let
>people make the conscious decision to break userspace and no longer
>expose the original master/slave interfaces, once their userspace is
>able to cope with their removal.

	I'm opposed to the Kconfig option because it will lead to
balkanization of the UAPI, which would be worse than a clean break
(which I'm also opposed to).

>Lastly, we do still have the issue of ease of backporting fixes to
>-stable trees. I've not had a huge amount of time to spend on it, but
>brief forays into coccinelle didn't really pay off (since it's meant to
>operate on code, not patches), and the best solution I can come up with
>is providing a shell script someone could run over git-format-patch
>output before git-am'ing the result to a -stable tree, though scripting
>these changes in the first place turned out to be not the best thing to
>do anyway, due to subtle cases where use of master or slave can NOT yet
>be replaced, so a large amount of work was done by hand, inspection,
>trial and error, which is why this set is a lot longer in coming than
>I'd originally hoped. I don't expect -stable backports to be horrible to
>figure out one way or another though, and I don't believe that a bit of
>inconvenience on that front is enough to warrant not making these

	I'm skeptical that, given the scope of the changes involved,
that it's really feasible to have effective automated massaging of
patches.  I think the reality is that a large fraction of the bonding
fixes in the future will have to be backported entirely by hand.  The
only saving grace here is that the quantity of such patches is generally
low (~40 in 2020 year to date).


>See here for further details on Red Hat's commitment to this work:
>As far as testing goes, I've manually operated on various bonds while
>working on this code, and have run it through multiple lnst test runs,
>which exercises the existing sysfs interfaces fairly extensively. As far
>as I can tell, there is no breakage of existing interfaces with this
>set, unless the user consciously opts to do so via Kconfig.
>Jarod Wilson (5):
>  bonding: rename struct slave member link to link_state
>  bonding: rename slave to link where possible
>  bonding: rename master to aggregator where possible
>  bonding: make Kconfig toggle to disable legacy interfaces
>  bonding: update Documentation for link/aggregator terminology
>Cc: Jay Vosburgh <>
>Cc: Veaceslav Falico <>
>Cc: Andy Gospodarek <>
>Cc: "David S. Miller" <>
>Cc: Jakub Kicinski <>
>Cc: Thomas Davis <>
> .clang-format                                 |    4 +-
> Documentation/networking/bonding.rst          |  440 ++--
> drivers/infiniband/core/cma.c                 |    2 +-
> drivers/infiniband/core/lag.c                 |    2 +-
> drivers/infiniband/core/roce_gid_mgmt.c       |   10 +-
> drivers/infiniband/hw/mlx4/main.c             |    2 +-
> drivers/net/Kconfig                           |   12 +
> drivers/net/bonding/Makefile                  |    2 +-
> drivers/net/bonding/bond_3ad.c                |  604 ++---
> drivers/net/bonding/bond_alb.c                |  687 ++---
> drivers/net/bonding/bond_debugfs.c            |    2 +-
> drivers/net/bonding/bond_main.c               | 2336 +++++++++--------
> drivers/net/bonding/bond_netlink.c            |  104 +-
> drivers/net/bonding/bond_options.c            |  258 +-
> drivers/net/bonding/bond_procfs.c             |   63 +-
> drivers/net/bonding/bond_sysfs.c              |  249 +-
> drivers/net/bonding/bond_sysfs_link.c         |  193 ++
> drivers/net/bonding/bond_sysfs_slave.c        |  176 --
> .../ethernet/chelsio/cxgb3/cxgb3_offload.c    |    2 +-
> .../net/ethernet/mellanox/mlx4/en_netdev.c    |    4 +-
> .../ethernet/mellanox/mlx5/core/en/rep/bond.c |    2 +-
> .../net/ethernet/mellanox/mlx5/core/en_tc.c   |    2 +-
> .../ethernet/netronome/nfp/flower/lag_conf.c  |    2 +-
> .../ethernet/qlogic/netxen/netxen_nic_main.c  |   12 +-
> include/linux/netdevice.h                     |   20 +-
> include/net/bond_3ad.h                        |   20 +-
> include/net/bond_alb.h                        |   31 +-
> include/net/bond_options.h                    |   19 +-
> include/net/bonding.h                         |  351 +--
> include/net/lag.h                             |    2 +-
> 30 files changed, 2902 insertions(+), 2711 deletions(-)
> create mode 100644 drivers/net/bonding/bond_sysfs_link.c
> delete mode 100644 drivers/net/bonding/bond_sysfs_slave.c

	-Jay Vosburgh,

Powered by blists - more mailing lists