[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20201208184856.GM2475764@lunn.ch>
Date: Tue, 8 Dec 2020 19:48:56 +0100
From: Andrew Lunn <andrew@...n.ch>
To: Claudiu Beznea <claudiu.beznea@...rochip.com>
Cc: davem@...emloft.net, kuba@...nel.org, robh+dt@...nel.org,
nicolas.ferre@...rochip.com, linux@...linux.org.uk,
paul.walmsley@...ive.com, palmer@...belt.com, yash.shah@...ive.com,
netdev@...r.kernel.org, devicetree@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-riscv@...ts.infradead.org
Subject: Re: [PATCH v2 3/8] net: macb: add function to disable all macb clocks
Hi Claudiu
> static int macb_clk_init(struct platform_device *pdev, struct clk **pclk,
> struct clk **hclk, struct clk **tx_clk,
> struct clk **rx_clk, struct clk **tsu_clk)
> @@ -3743,40 +3753,37 @@ static int macb_clk_init(struct platform_device *pdev, struct clk **pclk,
> err = clk_prepare_enable(*hclk);
> if (err) {
> dev_err(&pdev->dev, "failed to enable hclk (%d)\n", err);
> - goto err_disable_pclk;
> + hclk = NULL;
> + tx_clk = NULL;
> + rx_clk = NULL;
> + goto err_disable_clks;
> }
>
> err = clk_prepare_enable(*tx_clk);
> if (err) {
> dev_err(&pdev->dev, "failed to enable tx_clk (%d)\n", err);
> - goto err_disable_hclk;
> + tx_clk = NULL;
> + rx_clk = NULL;
> + goto err_disable_clks;
> }
>
> err = clk_prepare_enable(*rx_clk);
> if (err) {
> dev_err(&pdev->dev, "failed to enable rx_clk (%d)\n", err);
> - goto err_disable_txclk;
> + rx_clk = NULL;
> + goto err_disable_clks;
> }
>
> err = clk_prepare_enable(*tsu_clk);
> if (err) {
> dev_err(&pdev->dev, "failed to enable tsu_clk (%d)\n", err);
> - goto err_disable_rxclk;
> + goto err_disable_clks;
> }
>
> return 0;
>
> -err_disable_rxclk:
> - clk_disable_unprepare(*rx_clk);
> -
> -err_disable_txclk:
> - clk_disable_unprepare(*tx_clk);
> -
> -err_disable_hclk:
> - clk_disable_unprepare(*hclk);
> -
> -err_disable_pclk:
> - clk_disable_unprepare(*pclk);
> +err_disable_clks:
> + macb_clks_disable(*pclk, *hclk, *tx_clk, *rx_clk, NULL);
Personal taste, but i would of not changed this.
>
> return err;
> }
> @@ -4755,11 +4762,7 @@ static int macb_probe(struct platform_device *pdev)
> free_netdev(dev);
>
> err_disable_clocks:
> - clk_disable_unprepare(tx_clk);
> - clk_disable_unprepare(hclk);
> - clk_disable_unprepare(pclk);
> - clk_disable_unprepare(rx_clk);
> - clk_disable_unprepare(tsu_clk);
> + macb_clks_disable(bp->pclk, bp->hclk, bp->tx_clk, bp->rx_clk, bp->tsu_clk);
> pm_runtime_disable(&pdev->dev);
> pm_runtime_set_suspended(&pdev->dev);
> pm_runtime_dont_use_autosuspend(&pdev->dev);
> @@ -4784,11 +4787,8 @@ static int macb_remove(struct platform_device *pdev)
> pm_runtime_disable(&pdev->dev);
> pm_runtime_dont_use_autosuspend(&pdev->dev);
> if (!pm_runtime_suspended(&pdev->dev)) {
> - clk_disable_unprepare(bp->tx_clk);
> - clk_disable_unprepare(bp->hclk);
> - clk_disable_unprepare(bp->pclk);
> - clk_disable_unprepare(bp->rx_clk);
> - clk_disable_unprepare(bp->tsu_clk);
> + macb_clks_disable(bp->pclk, bp->hclk, bp->tx_clk,
> + bp->rx_clk, bp->tsu_clk);
> pm_runtime_set_suspended(&pdev->dev);
> }
> phylink_destroy(bp->phylink);
> @@ -4966,14 +4966,16 @@ static int __maybe_unused macb_runtime_suspend(struct device *dev)
> {
> struct net_device *netdev = dev_get_drvdata(dev);
> struct macb *bp = netdev_priv(netdev);
> + struct clk *pclk = NULL, *hclk = NULL, *tx_clk = NULL, *rx_clk = NULL;
>
> if (!(device_may_wakeup(dev))) {
> - clk_disable_unprepare(bp->tx_clk);
> - clk_disable_unprepare(bp->hclk);
> - clk_disable_unprepare(bp->pclk);
> - clk_disable_unprepare(bp->rx_clk);
> + pclk = bp->pclk;
> + hclk = bp->hclk;
> + tx_clk = bp->tx_clk;
> + rx_clk = bp->rx_clk;
> }
> - clk_disable_unprepare(bp->tsu_clk);
> +
> + macb_clks_disable(pclk, hclk, tx_clk, rx_clk, bp->tsu_clk);
Maybe
if (!(device_may_wakeup(dev)))
macb_clks_disable(bp->pclk, bp->hclk, pb->tx_clk, bp->rx_clk, bp->tsu_clk);
else
macb_clks_disable(NULL, NULL, NULL, NULL, bp->tsu_clk);
is more readable?
Andrew
Powered by blists - more mailing lists