lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 9 Dec 2020 22:46:47 +0800
From:   kernel test robot <lkp@...el.com>
To:     Aleksander Jan Bajkowski <olek2@...pl>, hauke@...ke-m.de,
        andrew@...n.ch, vivien.didelot@...il.com, f.fainelli@...il.com,
        olteanv@...il.com, davem@...emloft.net, kuba@...nel.org,
        robh+dt@...nel.org, netdev@...r.kernel.org,
        devicetree@...r.kernel.org
Cc:     kbuild-all@...ts.01.org
Subject: Re: [PATCH v2 1/2] net: dsa: lantiq: allow to use all GPHYs on
 xRX300 and xRX330

Hi Aleksander,

Thank you for the patch! Perhaps something to improve:

[auto build test WARNING on robh/for-next]
[also build test WARNING on net-next/master net/master linus/master sparc-next/master v5.10-rc7 next-20201208]
[If your patch is applied to the wrong git tree, kindly drop us a note.
And when submitting patch, we suggest to use '--base' as documented in
https://git-scm.com/docs/git-format-patch]

url:    https://github.com/0day-ci/linux/commits/Aleksander-Jan-Bajkowski/net-dsa-lantiq-add-support-for-xRX300-and-xRX330/20201206-213318
base:   https://git.kernel.org/pub/scm/linux/kernel/git/robh/linux.git for-next
config: x86_64-randconfig-s022-20201209 (attached as .config)
compiler: gcc-9 (Debian 9.3.0-15) 9.3.0
reproduce:
        # apt-get install sparse
        # sparse version: v0.6.3-179-ga00755aa-dirty
        # https://github.com/0day-ci/linux/commit/3a3400f9d3cd41f2b72cd741f208a70fca7fe93f
        git remote add linux-review https://github.com/0day-ci/linux
        git fetch --no-tags linux-review Aleksander-Jan-Bajkowski/net-dsa-lantiq-add-support-for-xRX300-and-xRX330/20201206-213318
        git checkout 3a3400f9d3cd41f2b72cd741f208a70fca7fe93f
        # save the attached .config to linux build tree
        make W=1 C=1 CF='-fdiagnostic-prefix -D__CHECK_ENDIAN__' ARCH=x86_64 

If you fix the issue, kindly add following tag as appropriate
Reported-by: kernel test robot <lkp@...el.com>


"sparse warnings: (new ones prefixed by >>)"
>> drivers/net/dsa/lantiq_gswip.c:2068:17: sparse: sparse: incorrect type in initializer (different modifiers) @@     expected struct dsa_switch_ops *ops @@     got struct dsa_switch_ops const * @@
   drivers/net/dsa/lantiq_gswip.c:2068:17: sparse:     expected struct dsa_switch_ops *ops
   drivers/net/dsa/lantiq_gswip.c:2068:17: sparse:     got struct dsa_switch_ops const *
   drivers/net/dsa/lantiq_gswip.c:2074:17: sparse: sparse: incorrect type in initializer (different modifiers) @@     expected struct dsa_switch_ops *ops @@     got struct dsa_switch_ops const * @@
   drivers/net/dsa/lantiq_gswip.c:2074:17: sparse:     expected struct dsa_switch_ops *ops
   drivers/net/dsa/lantiq_gswip.c:2074:17: sparse:     got struct dsa_switch_ops const *

vim +2068 drivers/net/dsa/lantiq_gswip.c

  2064	
  2065	static const struct gswip_hw_info gswip_xrx200 = {
  2066		.max_ports = 7,
  2067		.cpu_port = 6,
> 2068		.ops = &gswip_xrx200_switch_ops,
  2069	};
  2070	

---
0-DAY CI Kernel Test Service, Intel Corporation
https://lists.01.org/hyperkitty/list/kbuild-all@lists.01.org

Download attachment ".config.gz" of type "application/gzip" (31314 bytes)

Powered by blists - more mailing lists