lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 17 Dec 2020 16:28:54 -0500
From:   Willem de Bruijn <>
To:     Jakub Kicinski <>
Cc:     Baruch Siach <>,
        "David S. Miller" <>,
        Jonathan Corbet <>,
        Network Development <>,,
        Ulisses Alonso CamarĂ³ <>
Subject: Re: [PATCH net 2/2] docs: networking: packet_mmap: don't mention PACKET_MMAP

On Thu, Dec 17, 2020 at 2:48 PM Jakub Kicinski <> wrote:
> On Tue, 15 Dec 2020 18:51:17 +0200 Baruch Siach wrote:
> > Before commit 889b8f964f2f ("packet: Kill CONFIG_PACKET_MMAP.") there
> > used to be a CONFIG_PACKET_MMAP config symbol that depended on
> > CONFIG_PACKET. The text still refers to PACKET_MMAP as the name of this
> > feature, implying that it can be disabled. Another naming variant is
> > "Packet MMAP".
> >
> > Use "PACKET mmap()" everywhere to unify the terminology. Rephrase the
> > text the implied mmap() feature disable option.
> Should we maybe say AF_PACKET mmap() ?

I don't think that the feature name PACKET_MMAP implies
CONFIG_PACKET_MMAP, or thus that the name is obsolete now that the
latter is.

If it needs a rename, the setsockopt is PACKET_[RT]X_RING. So, if this
needs updating, perhaps PACKET_RING would be suitable. Or TPACKET,
based on the version definitions.

Powered by blists - more mailing lists