lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sun, 20 Dec 2020 09:52:55 +0200
From:   Baruch Siach <>
To:     Jakub Kicinski <>
Cc:     "David S. Miller" <>,
        Jonathan Corbet <>,,,
        Ulisses Alonso CamarĂ³ <>
Subject: Re: [PATCH net 2/2] docs: networking: packet_mmap: don't mention

Hi Jakub,

On Thu, Dec 17 2020, Jakub Kicinski wrote:
> On Tue, 15 Dec 2020 18:51:17 +0200 Baruch Siach wrote:
>> Before commit 889b8f964f2f ("packet: Kill CONFIG_PACKET_MMAP.") there
>> used to be a CONFIG_PACKET_MMAP config symbol that depended on
>> CONFIG_PACKET. The text still refers to PACKET_MMAP as the name of this
>> feature, implying that it can be disabled. Another naming variant is
>> "Packet MMAP".
>> Use "PACKET mmap()" everywhere to unify the terminology. Rephrase the
>> text the implied mmap() feature disable option.
> Should we maybe say AF_PACKET mmap() ?

I thought that PACKET is better because it is the minimal change, and
because of the reference to CONFIG_PACKET. Should we rename

What do you think?


                                                     ~. .~   Tk Open Systems
   - - tel: +972.52.368.4656, -

Powered by blists - more mailing lists