lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sun, 20 Dec 2020 09:58:36 +0200
From:   Baruch Siach <baruch@...s.co.il>
To:     Willem de Bruijn <willemdebruijn.kernel@...il.com>
Cc:     Jakub Kicinski <kuba@...nel.org>,
        "David S. Miller" <davem@...emloft.net>,
        Jonathan Corbet <corbet@....net>,
        Network Development <netdev@...r.kernel.org>,
        linux-doc@...r.kernel.org,
        Ulisses Alonso CamarĂ³ <uaca@...mni.uv.es>
Subject: Re: [PATCH net 2/2] docs: networking: packet_mmap: don't mention
 PACKET_MMAP

Hi Willem,

On Thu, Dec 17 2020, Willem de Bruijn wrote:
> On Thu, Dec 17, 2020 at 2:48 PM Jakub Kicinski <kuba@...nel.org> wrote:
>>
>> On Tue, 15 Dec 2020 18:51:17 +0200 Baruch Siach wrote:
>> > Before commit 889b8f964f2f ("packet: Kill CONFIG_PACKET_MMAP.") there
>> > used to be a CONFIG_PACKET_MMAP config symbol that depended on
>> > CONFIG_PACKET. The text still refers to PACKET_MMAP as the name of this
>> > feature, implying that it can be disabled. Another naming variant is
>> > "Packet MMAP".
>> >
>> > Use "PACKET mmap()" everywhere to unify the terminology. Rephrase the
>> > text the implied mmap() feature disable option.
>>
>> Should we maybe say AF_PACKET mmap() ?
>
> I don't think that the feature name PACKET_MMAP implies
> CONFIG_PACKET_MMAP, or thus that the name is obsolete now that the
> latter is.

Current text says "if PACKET_MMAP is not enabled ...". This clearly
implies a CONFIG_ symbol. Besides, the PACKET_MMAP term is mentioned
nowhere else in the source tree. At the very least we need to clarify
what it means.

> If it needs a rename, the setsockopt is PACKET_[RT]X_RING. So, if this
> needs updating, perhaps PACKET_RING would be suitable. Or TPACKET,
> based on the version definitions.

So how would you rephrase text like "PACKET_MMAP provides a size
configurable circular buffer ..."?

baruch

-- 
                                                     ~. .~   Tk Open Systems
=}------------------------------------------------ooO--U--Ooo------------{=
   - baruch@...s.co.il - tel: +972.52.368.4656, http://www.tkos.co.il -

Powered by blists - more mailing lists