lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 11 Mar 2021 08:28:49 -0700
From:   David Ahern <dsahern@...il.com>
To:     Petr Machata <petrm@...dia.com>, netdev@...r.kernel.org
Cc:     Ido Schimmel <idosch@...dia.com>, David Ahern <dsahern@...nel.org>,
        "David S . Miller" <davem@...emloft.net>,
        Jakub Kicinski <kuba@...nel.org>
Subject: Re: [PATCH net-next 03/14] nexthop: Add a dedicated flag for
 multipath next-hop groups

On 3/10/21 8:02 AM, Petr Machata wrote:
> With the introduction of resilient nexthop groups, there will be two types
> of multipath groups: the current hash-threshold "mpath" ones, and resilient
> groups. Both are multipath, but to determine the fact, the system needs to
> consider two flags. This might prove costly in the datapath. Therefore,
> introduce a new flag, that should be set for next-hop groups that have more
> than one nexthop, and should be considered multipath.
> 
> Signed-off-by: Petr Machata <petrm@...dia.com>
> Reviewed-by: Ido Schimmel <idosch@...dia.com>
> ---
> 
> Notes:
>     v1 (changes since RFC):
>     - This patch is new
> 
>  include/net/nexthop.h | 7 ++++---
>  net/ipv4/nexthop.c    | 5 ++++-
>  2 files changed, 8 insertions(+), 4 deletions(-)

This patch looks good:
Reviewed-by: David Ahern <dsahern@...nel.org>

> 
> diff --git a/include/net/nexthop.h b/include/net/nexthop.h
> index 7bc057aee40b..5062c2c08e2b 100644
> --- a/include/net/nexthop.h
> +++ b/include/net/nexthop.h
> @@ -80,6 +80,7 @@ struct nh_grp_entry {
>  struct nh_group {
>  	struct nh_group		*spare; /* spare group for removals */
>  	u16			num_nh;
> +	bool			is_multipath;
>  	bool			mpath;


It would be good to rename the existing type 'mpath' to something else.
You have 'resilient' as a group type later, so maybe rename this one to
hash or hash_threshold.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ