[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <757eb986-d3cc-322a-64e8-3b23a3dd07d3@gmail.com>
Date: Wed, 6 Oct 2021 22:45:58 +0300
From: Sergei Shtylyov <sergei.shtylyov@...il.com>
To: Biju Das <biju.das.jz@...renesas.com>,
Sergey Shtylyov <s.shtylyov@....ru>,
"David S. Miller" <davem@...emloft.net>,
Jakub Kicinski <kuba@...nel.org>
Cc: Geert Uytterhoeven <geert+renesas@...der.be>,
Sergey Shtylyov <s.shtylyov@...russia.ru>,
Adam Ford <aford173@...il.com>, Andrew Lunn <andrew@...n.ch>,
Yuusuke Ashizuka <ashiduka@...itsu.com>,
Yoshihiro Shimoda <yoshihiro.shimoda.uh@...esas.com>,
"netdev@...r.kernel.org" <netdev@...r.kernel.org>,
"linux-renesas-soc@...r.kernel.org"
<linux-renesas-soc@...r.kernel.org>,
Chris Paterson <Chris.Paterson2@...esas.com>,
Biju Das <biju.das@...renesas.com>,
Prabhakar Mahadev Lad <prabhakar.mahadev-lad.rj@...renesas.com>
Subject: Re: [PATCH 03/10] ravb: Add nc_queue to struct ravb_hw_info
On 10/3/21 9:58 AM, Biju Das wrote:
>>> R-Car supports network control queue whereas RZ/G2L does not support
>>> it. Add nc_queue to struct ravb_hw_info, so that NC queue is handled
>>> only by R-Car.
>>>
>>> This patch also renames ravb_rcar_dmac_init to ravb_dmac_init_rcar to
>>> be consistent with the naming convention used in sh_eth driver.
>>>
>>> Signed-off-by: Biju Das <biju.das.jz@...renesas.com>
>>> Reviewed-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@...renesas.com>
>>
>> Reviewed-by: Sergey Shtylyov <s.shtylyov@....ru>
>>
>> One little nit below:
>>
>>> ---
>>> RFC->v1:
>>> * Handled NC queue only for R-Car.
>>> ---
>>> drivers/net/ethernet/renesas/ravb.h | 3 +-
>>> drivers/net/ethernet/renesas/ravb_main.c | 140
>>> +++++++++++++++--------
>>> 2 files changed, 94 insertions(+), 49 deletions(-)
>>>
>>> diff --git a/drivers/net/ethernet/renesas/ravb.h
>>> b/drivers/net/ethernet/renesas/ravb.h
>>> index a33fbcb4aac3..c91e93e5590f 100644
>>> --- a/drivers/net/ethernet/renesas/ravb.h
>>> +++ b/drivers/net/ethernet/renesas/ravb.h
>>> @@ -986,7 +986,7 @@ struct ravb_hw_info {
>>> bool (*receive)(struct net_device *ndev, int *quota, int q);
>>> void (*set_rate)(struct net_device *ndev);
>>> int (*set_feature)(struct net_device *ndev, netdev_features_t
>> features);
>>> - void (*dmac_init)(struct net_device *ndev);
>>> + int (*dmac_init)(struct net_device *ndev);
>>> void (*emac_init)(struct net_device *ndev);
>>> const char (*gstrings_stats)[ETH_GSTRING_LEN];
>>> size_t gstrings_size;
>>> @@ -1002,6 +1002,7 @@ struct ravb_hw_info {
>>> unsigned multi_irqs:1; /* AVB-DMAC and E-MAC has multiple
>> irqs */
>>> unsigned gptp:1; /* AVB-DMAC has gPTP support */
>>> unsigned ccc_gac:1; /* AVB-DMAC has gPTP support active in
>> config mode */
>>> + unsigned nc_queue:1; /* AVB-DMAC has NC queue */
>>
>> Rather "queues" as there are RX and TX NC queues, no?
>
> It has NC queue on both RX and TX.
>
> If needed, I can send a follow up patch as RFC with the following changes.
>
> unsigned nc_queue:1; /* AVB-DMAC has NC queue on both RX and TX */
>
> or
>
> unsigned nc_queues:1; /* AVB-DMAC has RX and TX NC queues */
>
> please let me know.
Yes, please do it.
> Regards,
> Biju
MNR, Sergey
Powered by blists - more mailing lists