[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20211006230543.3928580-3-joannekoong@fb.com>
Date: Wed, 6 Oct 2021 16:05:42 -0700
From: Joanne Koong <joannekoong@...com>
To: <bpf@...r.kernel.org>
CC: <kafai@...com>, <netdev@...r.kernel.org>, <Kernel-team@...com>,
Joanne Koong <joannekoong@...com>
Subject: [PATCH bpf-next v2 2/3] bpf/selftests: Rename test_tcp_hdr_options to test_sockops_tcp_hdr_options
Currently, tcp_hdr_options is only supported for sockops type programs.
This patchset adds xdp tcp_hdr_options support. To more easily
differentiate between these two tests, this patch does the following
renames (with no functional changes):
test_tcp_hdr_options -> test_sockops_tcp_hdr_options
test_misc_tcp_hdr_options -> test_sockops_misc_tcp_hdr_options
The next patch will add xdp_test_tcp_hdr_options.
Signed-off-by: Joanne Koong <joannekoong@...com>
---
...hdr_options.c => sockops_tcp_hdr_options.c} | 18 +++++++++---------
...s.c => test_sockops_misc_tcp_hdr_options.c} | 0
...ptions.c => test_sockops_tcp_hdr_options.c} | 0
3 files changed, 9 insertions(+), 9 deletions(-)
rename tools/testing/selftests/bpf/prog_tests/{tcp_hdr_options.c => sockops_tcp_hdr_options.c} (96%)
rename tools/testing/selftests/bpf/progs/{test_misc_tcp_hdr_options.c => test_sockops_misc_tcp_hdr_options.c} (100%)
rename tools/testing/selftests/bpf/progs/{test_tcp_hdr_options.c => test_sockops_tcp_hdr_options.c} (100%)
diff --git a/tools/testing/selftests/bpf/prog_tests/tcp_hdr_options.c b/tools/testing/selftests/bpf/prog_tests/sockops_tcp_hdr_options.c
similarity index 96%
rename from tools/testing/selftests/bpf/prog_tests/tcp_hdr_options.c
rename to tools/testing/selftests/bpf/prog_tests/sockops_tcp_hdr_options.c
index 1fa772079967..f8fb12f4c1ed 100644
--- a/tools/testing/selftests/bpf/prog_tests/tcp_hdr_options.c
+++ b/tools/testing/selftests/bpf/prog_tests/sockops_tcp_hdr_options.c
@@ -12,8 +12,8 @@
#include "cgroup_helpers.h"
#include "network_helpers.h"
#include "test_tcp_hdr_options.h"
-#include "test_tcp_hdr_options.skel.h"
-#include "test_misc_tcp_hdr_options.skel.h"
+#include "test_sockops_tcp_hdr_options.skel.h"
+#include "test_sockops_misc_tcp_hdr_options.skel.h"
#define LO_ADDR6 "::1"
#define CG_NAME "/tcpbpf-hdr-opt-test"
@@ -25,8 +25,8 @@ static struct bpf_test_option exp_active_fin_in;
static struct hdr_stg exp_passive_hdr_stg;
static struct hdr_stg exp_active_hdr_stg = { .active = true, };
-static struct test_misc_tcp_hdr_options *misc_skel;
-static struct test_tcp_hdr_options *skel;
+static struct test_sockops_misc_tcp_hdr_options *misc_skel;
+static struct test_sockops_tcp_hdr_options *skel;
static int lport_linum_map_fd;
static int hdr_stg_map_fd;
static __u32 duration;
@@ -570,15 +570,15 @@ static struct test tests[] = {
DEF_TEST(misc),
};
-void test_tcp_hdr_options(void)
+void test_sockops_tcp_hdr_options(void)
{
int i;
- skel = test_tcp_hdr_options__open_and_load();
+ skel = test_sockops_tcp_hdr_options__open_and_load();
if (CHECK(!skel, "open and load skel", "failed"))
return;
- misc_skel = test_misc_tcp_hdr_options__open_and_load();
+ misc_skel = test_sockops_misc_tcp_hdr_options__open_and_load();
if (CHECK(!misc_skel, "open and load misc test skel", "failed"))
goto skel_destroy;
@@ -600,6 +600,6 @@ void test_tcp_hdr_options(void)
close(cg_fd);
skel_destroy:
- test_misc_tcp_hdr_options__destroy(misc_skel);
- test_tcp_hdr_options__destroy(skel);
+ test_sockops_misc_tcp_hdr_options__destroy(misc_skel);
+ test_sockops_tcp_hdr_options__destroy(skel);
}
diff --git a/tools/testing/selftests/bpf/progs/test_misc_tcp_hdr_options.c b/tools/testing/selftests/bpf/progs/test_sockops_misc_tcp_hdr_options.c
similarity index 100%
rename from tools/testing/selftests/bpf/progs/test_misc_tcp_hdr_options.c
rename to tools/testing/selftests/bpf/progs/test_sockops_misc_tcp_hdr_options.c
diff --git a/tools/testing/selftests/bpf/progs/test_tcp_hdr_options.c b/tools/testing/selftests/bpf/progs/test_sockops_tcp_hdr_options.c
similarity index 100%
rename from tools/testing/selftests/bpf/progs/test_tcp_hdr_options.c
rename to tools/testing/selftests/bpf/progs/test_sockops_tcp_hdr_options.c
--
2.30.2
Powered by blists - more mailing lists