[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAEf4BzaMgv5otr9AQGHZW=sUCuBdt_Vkv_GqB9n8BYVcZWHjAQ@mail.gmail.com>
Date: Mon, 18 Oct 2021 14:22:25 -0700
From: Andrii Nakryiko <andrii.nakryiko@...il.com>
To: Dave Marchevsky <davemarchevsky@...com>
Cc: bpf <bpf@...r.kernel.org>, Networking <netdev@...r.kernel.org>,
Alexei Starovoitov <ast@...nel.org>,
Daniel Borkmann <daniel@...earbox.net>,
Andrii Nakryiko <andrii@...nel.org>,
John Fastabend <john.fastabend@...il.com>
Subject: Re: [PATCH v2 bpf-next 1/2] bpf: add verified_insns to bpf_prog_info
and fdinfo
On Mon, Oct 11, 2021 at 1:54 PM Dave Marchevsky <davemarchevsky@...com> wrote:
>
> This stat is currently printed in the verifier log and not stored
> anywhere. To ease consumption of this data, add a field to bpf_prog_aux
> so it can be exposed via BPF_OBJ_GET_INFO_BY_FD and fdinfo.
>
> Signed-off-by: Dave Marchevsky <davemarchevsky@...com>
> ---
> include/linux/bpf.h | 1 +
> include/uapi/linux/bpf.h | 2 +-
> kernel/bpf/syscall.c | 8 ++++++--
> kernel/bpf/verifier.c | 1 +
> tools/include/uapi/linux/bpf.h | 2 +-
> 5 files changed, 10 insertions(+), 4 deletions(-)
>
[...]
> diff --git a/tools/include/uapi/linux/bpf.h b/tools/include/uapi/linux/bpf.h
> index 6fc59d61937a..d053fc7e7995 100644
> --- a/tools/include/uapi/linux/bpf.h
> +++ b/tools/include/uapi/linux/bpf.h
> @@ -5591,7 +5591,7 @@ struct bpf_prog_info {
> char name[BPF_OBJ_NAME_LEN];
> __u32 ifindex;
> __u32 gpl_compatible:1;
> - __u32 :31; /* alignment pad */
> + __u32 verified_insns:31;
These 31 unused bits seem like a good place to add extra generic
flags, not new counters. E.g., like a sleepable flag. So I wonder if
it's better to use a dedicated u32 field for counters like
verified_insns and keep these reserved fields for boolean flags?
Daniel, I know you proposed to reuse those 31 bits. How strong do you
feel about this? For any other kind of counter we seem to be using a
complete dedicated integer field, so it would be consistent to keep
doing that?
Having a sleepable bit still seems like a good idea, btw :) but it's a
separate change from Dave's.
> __u64 netns_dev;
> __u64 netns_ino;
> __u32 nr_jited_ksyms;
> --
> 2.30.2
>
Powered by blists - more mailing lists