lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 25 Mar 2022 08:58:58 -0700
From:   Jakub Kicinski <>
To:     Andrew Lunn <>
Cc:     "shenjian (K)" <>,,,,,,,,,
Subject: Re: [RFCv5 PATCH net-next 01/20] net: rename net_device->features
 to net_device->active_features

On Fri, 25 Mar 2022 16:52:29 +0100 Andrew Lunn wrote:
> > Here _hw_ makes sense. But i think we need some sort of
> > consistency. Either drop the _active_ from the function name, or
> > rename the netdev field active_features.  
> So i suggested an either/or. In retrospect, the or seems like a bad
> idea, this patch will be enormous. So i would suggest the other
> option, netdev_set_active_features() gets renamed to
> netdev_set__features()

SGTM! Just clarify if you meant the double underscore or it's a
coincidence? :)

Powered by blists - more mailing lists