lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 25 Mar 2022 16:52:29 +0100
From:   Andrew Lunn <>
To:     Jakub Kicinski <>
Cc:     "shenjian (K)" <>,,,,,,,,,
Subject: Re: [RFCv5 PATCH net-next 01/20] net: rename net_device->features to

On Thu, Mar 24, 2022 at 06:35:49PM -0700, Jakub Kicinski wrote:
> On Fri, 25 Mar 2022 09:29:51 +0800 shenjian (K) wrote:
> > 在 2022/3/25 9:03, Jakub Kicinski 写道:
> > > I see you mention that the work is not complete in the cover letter.
> > > Either way this patch seems unnecessary, you can call the helpers
> > > for "active" features like you do, but don't start by renaming the
> > > existing field. The patch will be enormous.
> > > .  
> > I agree that this patch will be enormous,  I made this patch from suggestion
> > from Andrew Lunn in RFCv3.[1]   Willit make people confused
> > for help name inconsistent with feature name ?
> > 
> > [1]
> Thanks, not sure if I see a suggestion there from Andrew or just 
> a question. Maybe you can add a comment instead to avoid surprising
> people?

Goes and looks at what i wrote.

> Here _hw_ makes sense. But i think we need some sort of
> consistency. Either drop the _active_ from the function name, or
> rename the netdev field active_features.

So i suggested an either/or. In retrospect, the or seems like a bad
idea, this patch will be enormous. So i would suggest the other
option, netdev_set_active_features() gets renamed to


Powered by blists - more mailing lists