lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <164941621857.19376.4332158800174528610.git-patchwork-notify@kernel.org>
Date:   Fri, 08 Apr 2022 11:10:18 +0000
From:   patchwork-bot+netdevbpf@...nel.org
To:     Michael Chan <michael.chan@...adcom.com>
Cc:     davem@...emloft.net, netdev@...r.kernel.org, kuba@...nel.org,
        gospo@...adcom.com, bpf@...r.kernel.org, john.fastabend@...il.com,
        toke@...hat.com, lorenzo@...nel.org, ast@...nel.org,
        daniel@...earbox.net, echaudro@...hat.com, pabeni@...hat.com
Subject: Re: [PATCH net-next v4 00/11] bnxt: Support XDP multi buffer

Hello:

This series was applied to netdev/net-next.git (master)
by David S. Miller <davem@...emloft.net>:

On Fri,  8 Apr 2022 03:58:55 -0400 you wrote:
> This series adds XDP multi buffer support, allowing MTU to go beyond
> the page size limit.
> 
> v4: Rebase with latest net-next
> v3: Simplify page mode buffer size calculation
>     Check to make sure XDP program supports multipage packets
> v2: Fix uninitialized variable warnings in patch 1 and 10.
> 
> [...]

Here is the summary with links:
  - [net-next,v4,01/11] bnxt: refactor bnxt_rx_xdp to separate xdp_init_buff/xdp_prepare_buff
    https://git.kernel.org/netdev/net-next/c/b231c3f3414c
  - [net-next,v4,02/11] bnxt: add flag to denote that an xdp program is currently attached
    https://git.kernel.org/netdev/net-next/c/ee536dcbdce4
  - [net-next,v4,03/11] bnxt: refactor bnxt_rx_pages operate on skb_shared_info
    https://git.kernel.org/netdev/net-next/c/ca1df2dd8e2f
  - [net-next,v4,04/11] bnxt: rename bnxt_rx_pages to bnxt_rx_agg_pages_skb
    https://git.kernel.org/netdev/net-next/c/23e4c0469ad0
  - [net-next,v4,05/11] bnxt: adding bnxt_rx_agg_pages_xdp for aggregated xdp
    https://git.kernel.org/netdev/net-next/c/4c6c123c9af9
  - [net-next,v4,06/11] bnxt: set xdp_buff pfmemalloc flag if needed
    https://git.kernel.org/netdev/net-next/c/31b9998bf225
  - [net-next,v4,07/11] bnxt: change receive ring space parameters
    https://git.kernel.org/netdev/net-next/c/32861236190b
  - [net-next,v4,08/11] bnxt: add page_pool support for aggregation ring when using xdp
    https://git.kernel.org/netdev/net-next/c/9a6aa3504885
  - [net-next,v4,09/11] bnxt: adding bnxt_xdp_build_skb to build skb from multibuffer xdp_buff
    https://git.kernel.org/netdev/net-next/c/1dc4c557bfed
  - [net-next,v4,10/11] bnxt: support transmit and free of aggregation buffers
    https://git.kernel.org/netdev/net-next/c/a7559bc8c17c
  - [net-next,v4,11/11] bnxt: XDP multibuffer enablement
    https://git.kernel.org/netdev/net-next/c/9f4b28301ce6

You are awesome, thank you!
-- 
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ