lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 13 May 2022 10:18:17 -0700
From:   Jakub Kicinski <>
To:     Eric Dumazet <>
Cc:     Oliver Hartkopp <>,
        Eric Dumazet <>,
        "David S . Miller" <>,
        Paolo Abeni <>,
        netdev <>
Subject: Re: [PATCH v2 net-next] inet: add READ_ONCE(sk->sk_bound_dev_if) in

On Thu, 12 May 2022 10:14:23 -0700 Eric Dumazet wrote:
> On Thu, May 12, 2022 at 10:02 AM Oliver Hartkopp <> wrote:
> > When you convert the #define into an inline function, wouldn't it be
> > more natural to name it lower caps?
> >
> > static inline bool inet_match(struct net *net, ... )  
> Sure, it is only a matter for us to remember all the past/present
> names, based on implementation details, especially at backport times.

We can apply as is if you prefer, but I'm not sure I follow TBH.
The prototype (arguments) of the function/macro have changed so there 
is nothing to be gained from not changing the name AFAICT, no?

Powered by blists - more mailing lists