[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20230127142621.1761278-1-yoshihiro.shimoda.uh@renesas.com>
Date: Fri, 27 Jan 2023 23:26:17 +0900
From: Yoshihiro Shimoda <yoshihiro.shimoda.uh@...esas.com>
To: linux@...linux.org.uk, andrew@...n.ch, hkallweit1@...il.com,
davem@...emloft.net, edumazet@...gle.com, kuba@...nel.org,
pabeni@...hat.com
Cc: netdev@...r.kernel.org, linux-renesas-soc@...r.kernel.org,
Yoshihiro Shimoda <yoshihiro.shimoda.uh@...esas.com>
Subject: [PATCH net-next v4 0/4] net: ethernet: renesas: rswitch: Modify initialization for SERDES and PHY
So, I would like to change the MACTYPE as SGMII by software for the platform.
The patch [1/4] sets phydev->host_interfaces by phylink for Marvell PHY
driver (marvell10g) to initialize the MACTYPE.
The patch [2/4] siplifies the rswitch driver, the patch [3/4] enables
the ovr_host_interfaces flag, and the patch [4/4] phy_power_on() calling
to initialize the Ethernet SERDES PHY driver (r8a779f0-eth-serdes)
for each channel.
Changes from v3:
https://lore.kernel.org/all/20230127014812.1656340-1-yoshihiro.shimoda.uh@renesas.com/
- Keep a pointer of "port" and more simplify the code.
Changes from v2:
- Add some blank lines for readability.
Changes from v1:
- Add a new flag (ovr_host_interfaces) into phylink_config in the patch [1/4].
- Add a new patch [3/4] for the new flag.
- Add a error message to the patch [4/4/] for MLO_AN_INBAND mode.
Yoshihiro Shimoda (4):
net: phylink: Set host_interfaces for a non-sfp PHY
net: ethernet: renesas: rswitch: Simplify struct phy * handling
net: ethernet: renesas: rswitch: Enable ovr_host_interfaces
net: ethernet: renesas: rswitch: Add phy_power_{on,off}() calling
drivers/net/ethernet/renesas/rswitch.c | 116 ++++++++-----------------
drivers/net/ethernet/renesas/rswitch.h | 2 +
drivers/net/phy/phylink.c | 11 +++
include/linux/phylink.h | 3 +
4 files changed, 54 insertions(+), 78 deletions(-)
--
2.25.1
Powered by blists - more mailing lists