[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1f68b7ee-b559-177b-650a-a8683fb86768@grimberg.me>
Date: Wed, 9 Aug 2023 11:03:11 +0300
From: Sagi Grimberg <sagi@...mberg.me>
To: Aurelien Aptel <aaptel@...dia.com>, linux-nvme@...ts.infradead.org,
netdev@...r.kernel.org, hch@....de, kbusch@...nel.org, axboe@...com,
chaitanyak@...dia.com, davem@...emloft.net, kuba@...nel.org
Cc: aurelien.aptel@...il.com, smalin@...dia.com, malin1024@...il.com,
ogerlitz@...dia.com, yorayz@...dia.com, borisp@...dia.com,
galshalom@...dia.com, mgurtovoy@...dia.com
Subject: Re: [PATCH v12 11/26] nvme-tcp: Add modparam to control the ULP
offload enablement
On 7/12/23 19:14, Aurelien Aptel wrote:
> Add ulp_offload module parameter to the nvme-tcp module to control
> ULP offload at the NVMe-TCP layer.
>
> Turn ULP offload off be default, regardless of the NIC driver support.
>
> Overall, in order to enable ULP offload:
> - nvme-tcp ulp_offload modparam must be set to 1
> - netdev->ulp_ddp_caps.active must have ULP_DDP_C_NVME_TCP and/or
> ULP_DDP_C_NVME_TCP_DDGST_RX capabilities flag set.
>
> Signed-off-by: Yoray Zack <yorayz@...dia.com>
> Signed-off-by: Shai Malin <smalin@...dia.com>
> Signed-off-by: Aurelien Aptel <aaptel@...dia.com>
> ---
> drivers/nvme/host/tcp.c | 12 +++++++++++-
> 1 file changed, 11 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/nvme/host/tcp.c b/drivers/nvme/host/tcp.c
> index e68e5da3df76..e560bdf3a023 100644
> --- a/drivers/nvme/host/tcp.c
> +++ b/drivers/nvme/host/tcp.c
> @@ -49,6 +49,16 @@ MODULE_PARM_DESC(tls_handshake_timeout,
> "nvme TLS handshake timeout in seconds (default 10)");
> #endif
>
> +#ifdef CONFIG_ULP_DDP
> +/* NVMeTCP direct data placement and data digest offload will not
> + * happen if this parameter false (default), regardless of what the
> + * underlying netdev capabilities are.
> + */
> +static bool ulp_offload;
> +module_param(ulp_offload, bool, 0644);
> +MODULE_PARM_DESC(ulp_offload, "Enable or disable NVMeTCP ULP support");
the name is strange.
maybe call it ddp_offload?
and in the description spell it as "direct data placement"
> +#endif
> +
> #ifdef CONFIG_DEBUG_LOCK_ALLOC
> /* lockdep can detect a circular dependency of the form
> * sk_lock -> mmap_lock (page fault) -> fs locks -> sk_lock
> @@ -350,7 +360,7 @@ static bool nvme_tcp_ddp_query_limits(struct net_device *netdev,
> static inline bool is_netdev_ulp_offload_active(struct net_device *netdev,
> struct nvme_tcp_queue *queue)
> {
> - if (!netdev || !queue)
> + if (!ulp_offload || !netdev || !queue)
> return false;
>
> /* If we cannot query the netdev limitations, do not offload */
This patch should be folded to the control path. No reason for it to
stand on its own I think.
Powered by blists - more mailing lists