[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CANn89iKZYsWGT1weXZ6W7_z28dqJwTZeg+2_Lw+x+6spUHp8Eg@mail.gmail.com>
Date: Fri, 10 Nov 2023 10:30:49 +0100
From: Eric Dumazet <edumazet@...gle.com>
To: Yan Zhai <yan@...udflare.com>
Cc: netdev@...r.kernel.org, "David S. Miller" <davem@...emloft.net>,
Jakub Kicinski <kuba@...nel.org>, Paolo Abeni <pabeni@...hat.com>,
Willem de Bruijn <willemdebruijn.kernel@...il.com>, Weongyo Jeong <weongyo.linux@...il.com>,
Ivan Babrou <ivan@...udflare.com>, David Ahern <dsahern@...nel.org>,
Jesper Brouer <jesper@...udflare.com>, linux-kernel@...r.kernel.org,
kernel-team@...udflare.com
Subject: Re: [PATCH net-next] packet: add a generic drop reason for receive
On Fri, Nov 10, 2023 at 6:49 AM Yan Zhai <yan@...udflare.com> wrote:
>
> Commit da37845fdce2 ("packet: uses kfree_skb() for errors.") switches
> from consume_skb to kfree_skb to improve error handling. However, this
> could bring a lot of noises when we monitor real packet drops in
> kfree_skb[1], because in tpacket_rcv or packet_rcv only packet clones
> can be freed, not actual packets.
>
> Adding a generic drop reason to allow distinguish these "clone drops".
>
> [1]: https://lore.kernel.org/netdev/CABWYdi00L+O30Q=Zah28QwZ_5RU-xcxLFUK2Zj08A8MrLk9jzg@mail.gmail.com/
> Fixes: da37845fdce2 ("packet: uses kfree_skb() for errors.")
> Signed-off-by: Yan Zhai <yan@...udflare.com>
> ---
> include/net/dropreason-core.h | 6 ++++++
> net/packet/af_packet.c | 16 +++++++++++++---
> 2 files changed, 19 insertions(+), 3 deletions(-)
>
> diff --git a/include/net/dropreason-core.h b/include/net/dropreason-core.h
> index 845dce805de7..6ff543fe8a8b 100644
> --- a/include/net/dropreason-core.h
> +++ b/include/net/dropreason-core.h
> @@ -81,6 +81,7 @@
> FN(IPV6_NDISC_NS_OTHERHOST) \
> FN(QUEUE_PURGE) \
> FN(TC_ERROR) \
> + FN(PACKET_SOCK_ERROR) \
> FNe(MAX)
>
> /**
> @@ -348,6 +349,11 @@ enum skb_drop_reason {
> SKB_DROP_REASON_QUEUE_PURGE,
> /** @SKB_DROP_REASON_TC_ERROR: generic internal tc error. */
> SKB_DROP_REASON_TC_ERROR,
> + /**
> + * @SKB_DROP_REASON_PACKET_SOCK_ERROR: generic packet socket errors
> + * after its filter matches an incoming packet.
> + */
> + SKB_DROP_REASON_PACKET_SOCK_ERROR,
> /**
> * @SKB_DROP_REASON_MAX: the maximum of core drop reasons, which
> * shouldn't be used as a real 'reason' - only for tracing code gen
> diff --git a/net/packet/af_packet.c b/net/packet/af_packet.c
> index a84e00b5904b..94b8a9d8e038 100644
> --- a/net/packet/af_packet.c
> +++ b/net/packet/af_packet.c
> @@ -2128,6 +2128,7 @@ static int packet_rcv(struct sk_buff *skb, struct net_device *dev,
> int skb_len = skb->len;
> unsigned int snaplen, res;
> bool is_drop_n_account = false;
> + enum skb_drop_reason drop_reason = SKB_DROP_REASON_NOT_SPECIFIED;
>
> if (skb->pkt_type == PACKET_LOOPBACK)
> goto drop;
> @@ -2161,6 +2162,10 @@ static int packet_rcv(struct sk_buff *skb, struct net_device *dev,
> res = run_filter(skb, sk, snaplen);
> if (!res)
> goto drop_n_restore;
> +
> + /* skb will only be "consumed" not "dropped" before this */
> + drop_reason = SKB_DROP_REASON_PACKET_SOCK_ERROR;
> +
> if (snaplen > res)
> snaplen = res;
>
> @@ -2230,7 +2235,7 @@ static int packet_rcv(struct sk_buff *skb, struct net_device *dev,
> if (!is_drop_n_account)
> consume_skb(skb);
> else
> - kfree_skb(skb);
> + kfree_skb_reason(skb, drop_reason);
> return 0;
1) Note that net-next is currently closed.
2) Now we have 0e84afe8ebfb ("net: dropreason: add SKB_CONSUMED reason")
it is time we replace the various constructs which do not help readability:
if (something)
consume_skb(skb);
else
kfree_skb_reason(skb, drop_reason);
By:
kfree_skb_reason(skb, drop_reason);
(By using drop_reason == SKB_CONSUMED when appropriate)
Powered by blists - more mailing lists