lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Mon, 4 Dec 2023 10:40:04 +0800
From: Liang Chen <liangchen.linux@...il.com>
To: Ilias Apalodimas <ilias.apalodimas@...aro.org>
Cc: davem@...emloft.net, edumazet@...gle.com, kuba@...nel.org, 
	pabeni@...hat.com, hawk@...nel.org, linyunsheng@...wei.com, 
	netdev@...r.kernel.org, linux-mm@...ck.org, jasowang@...hat.com
Subject: Re: [PATCH net-next v6 3/4] skbuff: Add a function to check if a page
 belongs to page_pool

On Fri, Dec 1, 2023 at 6:23 PM Ilias Apalodimas
<ilias.apalodimas@...aro.org> wrote:
>
> The second time is the charm, apologize for the noise.. resending it
> as plain-text
>
> On Thu, 30 Nov 2023 at 13:59, Liang Chen <liangchen.linux@...il.com> wrote:
> >
> > Wrap code for checking if a page is a page_pool page into a
> > function for better readability and ease of reuse.
> >
> > Signed-off-by: Liang Chen <liangchen.linux@...il.com>
> > Reviewed-by: Yunsheng Lin <linyunsheng@...wei.com>
> > ---
> >  net/core/skbuff.c | 7 ++++++-
> >  1 file changed, 6 insertions(+), 1 deletion(-)
> >
> > diff --git a/net/core/skbuff.c b/net/core/skbuff.c
> > index b157efea5dea..31e57c29c556 100644
> > --- a/net/core/skbuff.c
> > +++ b/net/core/skbuff.c
> > @@ -890,6 +890,11 @@ static void skb_clone_fraglist(struct sk_buff *skb)
> >                 skb_get(list);
> >  }
> >
> > +static bool skb_frag_is_pp_page(struct page *page)
> > +{
> > +       return (page->pp_magic & ~0x3UL) == PP_SIGNATURE;
> > +}
> > +
>
> That's fine, but why _frag? The same logic applies to non-fragmented pages no?
> So rename it to skb_from_pp()?
>

Yeah, the same logic applies to non-fragmented pages. How about
changing it to 'is_pp_page'? It takes a page as an argument instead of
the entire skb.
> [...]
>
> Thanks
> /Ilias

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ