[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <2a0f3c2a-71fe-4c79-8827-e53088bf3761@intel.com>
Date: Wed, 6 Dec 2023 13:40:07 +0100
From: Alexander Lobakin <aleksander.lobakin@...el.com>
To: Kunwu Chan <chentao@...inos.cn>
CC: <jesse.brandeburg@...el.com>, <anthony.l.nguyen@...el.com>,
<davem@...emloft.net>, <edumazet@...gle.com>, <kuba@...nel.org>,
<pabeni@...hat.com>, <jeffrey.t.kirsher@...el.com>, <shannon.nelson@....com>,
<kunwu.chan@...mail.com>, <netdev@...r.kernel.org>,
<linux-kernel@...r.kernel.org>, Simon Horman <horms@...nel.org>
Subject: Re: [PATCH v4 iwl-next] i40e: Use correct buffer size in
i40e_dbg_command_read
From: Kunwu Chan <chentao@...inos.cn>
Date: Tue, 5 Dec 2023 17:58:44 +0800
> The size of "i40e_dbg_command_buf" is 256, the size of "name"
> depends on "IFNAMSIZ", plus a null character and format size,
> the total size is more than 256.
>
> Improve readability and maintainability by replacing a hardcoded string
> allocation and formatting by the use of the kasprintf() helper.
>
> Fixes: 02e9c290814c ("i40e: debugfs interface")
> Signed-off-by: Kunwu Chan <chentao@...inos.cn>
> Suggested-by: Simon Horman <horms@...nel.org>
> Suggested-by: Alexander Lobakin <aleksander.lobakin@...el.com>
Your Signed-off-by must be the last tag in the block.
Perhaps the maintainer could fix it when taking, so that you wouldn't
need to send a new version only due to that.
> ---
> v2
> - Update the size calculation with IFNAMSIZ and sizeof(i40e_dbg_command_buf)
> v3
> - Use kasprintf to improve readability and maintainability
> v4
> - Fix memory leak in error path
> ---
> .../net/ethernet/intel/i40e/i40e_debugfs.c | 20 ++++++++++---------
> 1 file changed, 11 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/net/ethernet/intel/i40e/i40e_debugfs.c b/drivers/net/ethernet/intel/i40e/i40e_debugfs.c
> index 88240571721a..78a7200211b2 100644
> --- a/drivers/net/ethernet/intel/i40e/i40e_debugfs.c
> +++ b/drivers/net/ethernet/intel/i40e/i40e_debugfs.c
> @@ -72,29 +72,31 @@ static ssize_t i40e_dbg_command_read(struct file *filp, char __user *buffer,
> {
> struct i40e_pf *pf = filp->private_data;
> int bytes_not_copied;
> - int buf_size = 256;
> char *buf;
> int len;
>
> /* don't allow partial reads */
> if (*ppos != 0)
> return 0;
> - if (count < buf_size)
> - return -ENOSPC;
>
> - buf = kzalloc(buf_size, GFP_KERNEL);
> + buf = kasprintf(GFP_KERNEL, "%s: %s\n",
> + pf->vsi[pf->lan_vsi]->netdev->name,
> + i40e_dbg_command_buf);
> if (!buf)
> return -ENOSPC;
>
> - len = snprintf(buf, buf_size, "%s: %s\n",
> - pf->vsi[pf->lan_vsi]->netdev->name,
> - i40e_dbg_command_buf);
> + len = strlen(buf) + 1;
> + if (count < len)
> + bytes_not_copied = -ENOSPC;
> + else if (copy_to_user(buffer, buf, len))
> + bytes_not_copied = -EFAULT;
> + else
> + bytes_not_copied = 0;
>
> - bytes_not_copied = copy_to_user(buffer, buf, len);
> kfree(buf);
>
> if (bytes_not_copied)
> - return -EFAULT;
> + return bytes_not_copied;
>
> *ppos = len;
> return len;
For the code:
Reviewed-by: Alexander Lobakin <aleksander.lobakin@...el.com>
Thanks,
Olek
Powered by blists - more mailing lists