lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <be69cc3f-0ded-4c7e-8709-1602807d1914@linux.dev>
Date: Thu, 18 Jan 2024 14:25:00 -0800
From: Martin KaFai Lau <martin.lau@...ux.dev>
To: thinker.li@...il.com
Cc: sinquersw@...il.com, kuifeng@...a.com, netdev@...r.kernel.org,
 bpf@...r.kernel.org, ast@...nel.org, song@...nel.org, kernel-team@...a.com,
 andrii@...nel.org, drosen@...gle.com
Subject: Re: [PATCH bpf-next v16 11/14] bpf, net: switch to dynamic
 registration

On 1/17/24 5:49 PM, thinker.li@...il.com wrote:
> diff --git a/include/linux/bpf.h b/include/linux/bpf.h
> index 1cfbb89944c5..a2522fcfe57c 100644
> --- a/include/linux/bpf.h
> +++ b/include/linux/bpf.h
> @@ -1700,10 +1700,22 @@ struct bpf_struct_ops_common_value {
>   	enum bpf_struct_ops_state state;
>   };
>   
> +/* This macro helps developer to register a struct_ops type and generate
> + * type information correctly. Developers should use this macro to register
> + * a struct_ops type instead of calling register_bpf_struct_ops() directly.
> + */
> +#define REGISTER_BPF_STRUCT_OPS(st_ops, type)				\

One final nit on this macro. Rename this to register_bpf_struct_ops since it is 
the one will be used a lot, so give it an easier typing name.

> +	({								\
> +		struct bpf_struct_ops_##type {				\
> +			struct bpf_struct_ops_common_value common;	\
> +			struct type data ____cacheline_aligned_in_smp;	\
> +		};							\
> +		BTF_TYPE_EMIT(struct bpf_struct_ops_##type);		\
> +		register_bpf_struct_ops(st_ops);			\

and rename this to __register_bpf_struct_ops. Thanks.

> +	})
> +
>   #if defined(CONFIG_BPF_JIT) && defined(CONFIG_BPF_SYSCALL)
>   #define BPF_MODULE_OWNER ((void *)((0xeB9FUL << 2) + POISON_POINTER_DELTA))
> -const struct bpf_struct_ops_desc *bpf_struct_ops_find(struct btf *btf, u32 type_id);
> -void bpf_struct_ops_init(struct btf *btf, struct bpf_verifier_log *log);
>   bool bpf_struct_ops_get(const void *kdata);
>   void bpf_struct_ops_put(const void *kdata);
>   int bpf_struct_ops_map_sys_lookup_elem(struct bpf_map *map, void *key,
> @@ -1745,16 +1757,11 @@ struct bpf_dummy_ops {
>   int bpf_struct_ops_test_run(struct bpf_prog *prog, const union bpf_attr *kattr,
>   			    union bpf_attr __user *uattr);
>   #endif
> +int bpf_struct_ops_desc_init(struct bpf_struct_ops_desc *st_ops_desc,
> +			     struct btf *btf,
> +			     struct bpf_verifier_log *log);
>   void bpf_map_struct_ops_info_fill(struct bpf_map_info *info, struct bpf_map *map);
>   #else
> -static inline const struct bpf_struct_ops_desc *bpf_struct_ops_find(struct btf *btf, u32 type_id)
> -{
> -	return NULL;
> -}
> -static inline void bpf_struct_ops_init(struct btf *btf,
> -				       struct bpf_verifier_log *log)
> -{
> -}
>   static inline bool bpf_try_module_get(const void *data, struct module *owner)
>   {
>   	return try_module_get(owner);
> @@ -1769,6 +1776,10 @@ static inline int bpf_struct_ops_map_sys_lookup_elem(struct bpf_map *map,
>   {
>   	return -EINVAL;
>   }
> +static inline int bpf_struct_ops_link_create(union bpf_attr *attr)
> +{
> +	return -EOPNOTSUPP;
> +}

This is added back here which was removed in patch 3...

Others lgtm.


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ