[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CACGkMEtUE8CbdLS1c1b++g=ZxO_gDgOidUpWhuv28ZWgWP6uPw@mail.gmail.com>
Date: Mon, 17 Jun 2024 13:00:11 +0800
From: Jason Wang <jasowang@...hat.com>
To: Xuan Zhuo <xuanzhuo@...ux.alibaba.com>
Cc: netdev@...r.kernel.org, "Michael S. Tsirkin" <mst@...hat.com>,
Eugenio Pérez <eperezma@...hat.com>,
"David S. Miller" <davem@...emloft.net>, Eric Dumazet <edumazet@...gle.com>,
Jakub Kicinski <kuba@...nel.org>, Paolo Abeni <pabeni@...hat.com>, Alexei Starovoitov <ast@...nel.org>,
Daniel Borkmann <daniel@...earbox.net>, Jesper Dangaard Brouer <hawk@...nel.org>,
John Fastabend <john.fastabend@...il.com>, virtualization@...ts.linux.dev,
bpf@...r.kernel.org
Subject: Re: [PATCH net-next v5 07/15] virtio_net: refactor the xmit type
On Fri, Jun 14, 2024 at 2:40 PM Xuan Zhuo <xuanzhuo@...ux.alibaba.com> wrote:
>
> Because the af-xdp and sq premapped mode will introduce two
> new xmit type, so I refactor the xmit type mechanism first.
>
> We use the last two bits of the pointer to distinguish the xmit type,
> so we can distinguish four xmit types. Now we have two xmit types:
> SKB and XDP.
>
> Signed-off-by: Xuan Zhuo <xuanzhuo@...ux.alibaba.com>
> ---
> drivers/net/virtio_net.c | 58 +++++++++++++++++++++++++++-------------
> 1 file changed, 40 insertions(+), 18 deletions(-)
>
> diff --git a/drivers/net/virtio_net.c b/drivers/net/virtio_net.c
> index 161694957065..e84a4624549b 100644
> --- a/drivers/net/virtio_net.c
> +++ b/drivers/net/virtio_net.c
> @@ -47,8 +47,6 @@ module_param(napi_tx, bool, 0644);
> #define VIRTIO_XDP_TX BIT(0)
> #define VIRTIO_XDP_REDIR BIT(1)
>
> -#define VIRTIO_XDP_FLAG BIT(0)
> -
> /* RX packet size EWMA. The average packet size is used to determine the packet
> * buffer size when refilling RX rings. As the entire RX ring may be refilled
> * at once, the weight is chosen so that the EWMA will be insensitive to short-
> @@ -491,42 +489,62 @@ struct virtio_net_common_hdr {
>
> static void virtnet_sq_free_unused_buf(struct virtqueue *vq, void *buf);
>
> -static bool is_xdp_frame(void *ptr)
> +enum virtnet_xmit_type {
> + VIRTNET_XMIT_TYPE_SKB,
> + VIRTNET_XMIT_TYPE_XDP,
> +};
> +
> +#define VIRTNET_XMIT_TYPE_MASK (VIRTNET_XMIT_TYPE_SKB | VIRTNET_XMIT_TYPE_XDP)
> +
> +static enum virtnet_xmit_type virtnet_xmit_ptr_strip(void **ptr)
> {
> - return (unsigned long)ptr & VIRTIO_XDP_FLAG;
> + unsigned long p = (unsigned long)*ptr;
> +
> + *ptr = (void *)(p & ~VIRTNET_XMIT_TYPE_MASK);
> +
> + return p & VIRTNET_XMIT_TYPE_MASK;
> }
>
> -static void *xdp_to_ptr(struct xdp_frame *ptr)
> +static void *virtnet_xmit_ptr_mix(void *ptr, enum virtnet_xmit_type type)
How about rename this to virtnet_ptr_to_token()?
> {
> - return (void *)((unsigned long)ptr | VIRTIO_XDP_FLAG);
> + return (void *)((unsigned long)ptr | type);
> }
>
> -static struct xdp_frame *ptr_to_xdp(void *ptr)
> +static int virtnet_add_outbuf(struct send_queue *sq, int num, void *data,
> + enum virtnet_xmit_type type)
> {
> - return (struct xdp_frame *)((unsigned long)ptr & ~VIRTIO_XDP_FLAG);
> + return virtqueue_add_outbuf(sq->vq, sq->sg, num,
> + virtnet_xmit_ptr_mix(data, type),
> + GFP_ATOMIC);
Nit: I think we can just open-code this instead of using a helper.
Others look good.
Thanks
> }
>
> static void __free_old_xmit(struct send_queue *sq, bool in_napi,
> struct virtnet_sq_free_stats *stats)
> {
> + struct xdp_frame *frame;
> + struct sk_buff *skb;
> unsigned int len;
> void *ptr;
>
> while ((ptr = virtqueue_get_buf(sq->vq, &len)) != NULL) {
> ++stats->packets;
>
> - if (!is_xdp_frame(ptr)) {
> - struct sk_buff *skb = ptr;
> + switch (virtnet_xmit_ptr_strip(&ptr)) {
> + case VIRTNET_XMIT_TYPE_SKB:
> + skb = ptr;
>
> pr_debug("Sent skb %p\n", skb);
>
> stats->bytes += skb->len;
> napi_consume_skb(skb, in_napi);
> - } else {
> - struct xdp_frame *frame = ptr_to_xdp(ptr);
> + break;
> +
> + case VIRTNET_XMIT_TYPE_XDP:
> + frame = ptr;
>
> stats->bytes += xdp_get_frame_len(frame);
> xdp_return_frame(frame);
> + break;
> }
> }
> }
> @@ -1064,8 +1082,7 @@ static int __virtnet_xdp_xmit_one(struct virtnet_info *vi,
> skb_frag_size(frag), skb_frag_off(frag));
> }
>
> - err = virtqueue_add_outbuf(sq->vq, sq->sg, nr_frags + 1,
> - xdp_to_ptr(xdpf), GFP_ATOMIC);
> + err = virtnet_add_outbuf(sq, nr_frags + 1, xdpf, VIRTNET_XMIT_TYPE_XDP);
> if (unlikely(err))
> return -ENOSPC; /* Caller handle free/refcnt */
>
> @@ -2557,7 +2574,7 @@ static int xmit_skb(struct send_queue *sq, struct sk_buff *skb)
> return num_sg;
> num_sg++;
> }
> - return virtqueue_add_outbuf(sq->vq, sq->sg, num_sg, skb, GFP_ATOMIC);
> + return virtnet_add_outbuf(sq, num_sg, skb, VIRTNET_XMIT_TYPE_SKB);
> }
>
> static netdev_tx_t start_xmit(struct sk_buff *skb, struct net_device *dev)
> @@ -5263,10 +5280,15 @@ static void free_receive_page_frags(struct virtnet_info *vi)
>
> static void virtnet_sq_free_unused_buf(struct virtqueue *vq, void *buf)
> {
> - if (!is_xdp_frame(buf))
> + switch (virtnet_xmit_ptr_strip(&buf)) {
> + case VIRTNET_XMIT_TYPE_SKB:
> dev_kfree_skb(buf);
> - else
> - xdp_return_frame(ptr_to_xdp(buf));
> + break;
> +
> + case VIRTNET_XMIT_TYPE_XDP:
> + xdp_return_frame(buf);
> + break;
> + }
> }
>
> static void free_unused_bufs(struct virtnet_info *vi)
> --
> 2.32.0.3.g01195cf9f
>
Powered by blists - more mailing lists