[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250110114344.GA7706@kernel.org>
Date: Fri, 10 Jan 2025 11:43:44 +0000
From: Simon Horman <horms@...nel.org>
To: Kuniyuki Iwashima <kuniyu@...zon.com>
Cc: "David S. Miller" <davem@...emloft.net>,
Eric Dumazet <edumazet@...gle.com>,
Jakub Kicinski <kuba@...nel.org>, Paolo Abeni <pabeni@...hat.com>,
Donald Hunter <donald.hunter@...hat.com>,
Kuniyuki Iwashima <kuni1840@...il.com>, netdev@...r.kernel.org
Subject: Re: [PATCH v1 net-next 06/12] af_unix: Reuse out_pipe label in
unix_stream_sendmsg().
On Fri, Jan 10, 2025 at 06:26:35PM +0900, Kuniyuki Iwashima wrote:
> This is a follow-up of commit d460b04bc452 ("af_unix: Clean up
> error paths in unix_stream_sendmsg().").
>
> If we initialise skb with NULL in unix_stream_sendmsg(), we can
> reuse the existing out_pipe label for the SEND_SHUTDOWN check.
>
> Let's rename do it and adjust the existing label as out_pipe_lock.
>
> While at it, size and data_len are moved to the while loop scope.
>
> Suggested-by: Paolo Abeni <pabeni@...hat.com>
> Signed-off-by: Kuniyuki Iwashima <kuniyu@...zon.com>
> ---
> net/unix/af_unix.c | 23 +++++++++--------------
> 1 file changed, 9 insertions(+), 14 deletions(-)
>
> diff --git a/net/unix/af_unix.c b/net/unix/af_unix.c
> index b190ea8b8e9d..6505eeab9957 100644
> --- a/net/unix/af_unix.c
> +++ b/net/unix/af_unix.c
...
> @@ -2285,16 +2283,12 @@ static int unix_stream_sendmsg(struct socket *sock, struct msghdr *msg,
> }
> }
>
> - if (READ_ONCE(sk->sk_shutdown) & SEND_SHUTDOWN) {
> - if (!(msg->msg_flags & MSG_NOSIGNAL))
> - send_sig(SIGPIPE, current, 0);
> -
> - err = -EPIPE;
> - goto out_err;
> - }
> + if (READ_ONCE(sk->sk_shutdown) & SEND_SHUTDOWN)
Hi Iwashima-san,
I think you need to set reason here.
Flagged by W=1 builds with clang-19.
> + goto out_pipe;
>
> while (sent < len) {
> - size = len - sent;
> + int size = len - sent;
> + int data_len;
>
> if (unlikely(msg->msg_flags & MSG_SPLICE_PAGES)) {
> skb = sock_alloc_send_pskb(sk, 0, 0,
...
--
pw-bot: changes-requested
Powered by blists - more mailing lists