[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20250211183327.21d685cc@kernel.org>
Date: Tue, 11 Feb 2025 18:33:27 -0800
From: Jakub Kicinski <kuba@...nel.org>
To: Stanislav Fomichev <sdf@...ichev.me>
Cc: netdev@...r.kernel.org, davem@...emloft.net, edumazet@...gle.com,
pabeni@...hat.com, Saeed Mahameed <saeed@...nel.org>
Subject: Re: [PATCH net-next 04/11] net: hold netdev instance lock during
rtnetlink operations
On Mon, 10 Feb 2025 11:20:36 -0800 Stanislav Fomichev wrote:
> @@ -11468,6 +11387,18 @@ void netdev_sw_irq_coalesce_default_on(struct net_device *dev)
> }
> EXPORT_SYMBOL_GPL(netdev_sw_irq_coalesce_default_on);
>
> +static int netdev_lock_cmp_fn(const struct lockdep_map *a, const struct lockdep_map *b)
over 80 chars, fwiw
> +{
> + /* Only lower devices currently grab the instance lock, so no
> + * real ordering issues can occur. In the near future, only
> + * hardware devices will grab instance lock which also does not
> + * involve any ordering. Suppress lockdep ordering warnings
> + * until (if) we start grabbing instance lock on pure SW
> + * devices (bond/team/etc).
mentioning bond and team here may be misleading, add veth or dummy
into this list? Otherwise it may seem like it's about uppers.
For other devices we could probably sort the shutdown list, and
we would be good. But yeah, we can defer.
> +/**
> + * dev_change_name - change name of a device
> + * @dev: device
> + * @newname: name (or format string) must be at least IFNAMSIZ
> + *
> + * Change name of a device, can pass format strings "eth%d".
> + * for wildcarding.
Would you mind making these kdocs suck a bit less while we move them?
No tab indent.
round brackets and no tabs in first line, just:
* function() - short description
Document the return value in the kdoc way:
* Return: 0 on success, -errno on failure.
Powered by blists - more mailing lists