[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1160571242.19143.320.camel@amol.verismonetworks.com>
Date: Wed, 11 Oct 2006 18:24:02 +0530
From: Amol Lad <amol@...ismonetworks.com>
To: linux kernel <linux-kernel@...r.kernel.org>
Cc: James.Bottomley@...eleye.com,
kernel Janitors <kernel-janitors@...ts.osdl.org>
Subject: [PATCH 3/3] drivers/scsi/NCR5380.c: Replacing yield() with a
better alternative
For this driver schedule_timeout_schedule() seems to be a better
alternative.
*Please see if the function should be called with 1 jiffy delay or more
is better*
Signed-off-by: Amol Lad <amol@...ismonetworks.com>
---
diff -uprN -X linux-2.6.19-rc1-orig/Documentation/dontdiff linux-2.6.19-rc1-orig/drivers/scsi/NCR5380.c linux-2.6.19-rc1/drivers/scsi/NCR5380.c
--- linux-2.6.19-rc1-orig/drivers/scsi/NCR5380.c 2006-09-21 10:15:39.000000000 +0530
+++ linux-2.6.19-rc1/drivers/scsi/NCR5380.c 2006-10-11 17:57:02.000000000 +0530
@@ -347,7 +347,7 @@ static int NCR5380_poll_politely(struct
if((r & bit) == val)
return 0;
if(!in_interrupt())
- yield();
+ schedule_timeout_interruptible(1);
else
cpu_relax();
}
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists