[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <m3hb82aren.fsf@IBM-009124035060.in.ibm.com>
Date: Tue, 07 Jun 2011 15:34:48 +0530
From: "Nikunj A. Dadhania" <nikunj@...ux.vnet.ibm.com>
To: Peter Zijlstra <peterz@...radead.org>
Cc: mingo@...e.hu, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] sched: remove redundant check in select_task_rq_fair
On Tue, 07 Jun 2011 11:53:34 +0200, Peter Zijlstra <peterz@...radead.org> wrote:
> On Tue, 2011-06-07 at 15:18 +0530, Nikunj A. Dadhania wrote:
> > When balancing for wakeup affinity, a redundant check can removed.
>
> Yes, tempting, but no, now you've got an extra call to wake_affine(),
> which is more expensive.
Ah, got that. How about this, it is more readable. Other options would
be to add a comment.
Signed-off-by: Nikunj A. Dadhania <nikunj@...ux.vnet.ibm.com>
---
kernel/sched_fair.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/kernel/sched_fair.c b/kernel/sched_fair.c
index 433491c..354e26b 100644
--- a/kernel/sched_fair.c
+++ b/kernel/sched_fair.c
@@ -1753,7 +1753,7 @@ select_task_rq_fair(struct task_struct *p, int sd_flag, int wake_flags)
}
if (affine_sd) {
- if (cpu == prev_cpu || wake_affine(affine_sd, p, sync))
+ if (cpu != prev_cpu && wake_affine(affine_sd, p, sync))
prev_cpu = cpu;
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists