[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20209.30516.772365.586920@ipc1.ka-ro>
Date: Wed, 21 Dec 2011 07:05:40 +0100
From: Lothar Waßmann <LW@...O-electronics.de>
To: Dong Aisheng-B29396 <B29396@...escale.com>
Cc: Marek Vasut <marek.vasut@...il.com>,
"linux-arm-kernel\@lists.infradead.org"
<linux-arm-kernel@...ts.infradead.org>,
Guo Shawn-R65073 <r65073@...escale.com>,
"linus.walleij\@stericsson.com" <linus.walleij@...ricsson.com>,
"s.hauer\@pengutronix.de" <s.hauer@...gutronix.de>,
"w.sang\@pengutronix.de" <w.sang@...gutronix.de>,
"rob.herring\@calxeda.com" <rob.herring@...xeda.com>,
"linux-kernel\@vger.kernel.org" <linux-kernel@...r.kernel.org>,
"grant.likely\@secretlab.ca" <grant.likely@...retlab.ca>,
"kernel\@pengutronix.de" <kernel@...gutronix.de>,
"cjb\@laptop.org" <cjb@...top.org>,
"devicetree-discuss\@lists.ozlabs.org"
<devicetree-discuss@...ts.ozlabs.org>
Subject: RE: [RFC PATCH v3 1/5] dt: add of_get_child_count helper function
Hi,
Dong Aisheng-B29396 writes:
> > -----Original Message-----
> > From: Marek Vasut [mailto:marek.vasut@...il.com]
> > Sent: Wednesday, December 21, 2011 3:47 AM
> > To: linux-arm-kernel@...ts.infradead.org
> > Cc: Dong Aisheng-B29396; linux-kernel@...r.kernel.org;
> > linus.walleij@...ricsson.com; s.hauer@...gutronix.de; w.sang@...gutronix.de;
> > rob.herring@...xeda.com; grant.likely@...retlab.ca; kernel@...gutronix.de;
> > cjb@...top.org; devicetree-discuss@...ts.ozlabs.org; Guo Shawn-R65073
> > Subject: Re: [RFC PATCH v3 1/5] dt: add of_get_child_count helper function
> > Importance: High
> >
> > > From: Dong Aisheng <dong.aisheng@...aro.org>
> > >
> > > Currently most code to get child count in kernel are almost same, add
> > > a helper to implement this function for dt to use.
> > >
> > > ---
> > > Changes v1->v2:
> > > * change the name from of_get_child_number to of_get_child_count
> > >
> > > Signed-off-by: Dong Aisheng <dong.aisheng@...aro.org>
> > > Cc: Grant Likely <grant.likely@...retlab.ca>
> > > Cc: Rob Herring <rob.herring@...xeda.com>
> > > ---
> > > include/linux/of.h | 16 ++++++++++++++++
> > > 1 files changed, 16 insertions(+), 0 deletions(-)
> > >
> > > diff --git a/include/linux/of.h b/include/linux/of.h index
> > > 4948552..d0d91a1 100644
> > > --- a/include/linux/of.h
> > > +++ b/include/linux/of.h
> > > @@ -189,6 +189,17 @@ extern struct device_node
> > > *of_get_next_child(const struct device_node *node, for (child =
> > > of_get_next_child(parent, NULL); child != NULL; \
> > > child = of_get_next_child(parent, child))
> > >
> > > +static inline int of_get_child_count(const struct device_node *np) {
> > > + struct device_node *child = NULL;
> > > + int num = 0;
> > > +
> > > + while ((child = of_get_next_child(np, child)))
> >
> > The assignment in this condition really looks eerie, maybe just rewrite it to do
> > { } while () ? Also, aren't the parenthesis unnecessary?
> >
> Yes, one more parenthesis. I will remove it. Thanks.
> For the condition, it's a little trick but I guess for a helper function
> it's ok right? And there're already many places using like this.
>
It's a bad habit to use an assignment as an expression. It always
looks like someone used '=' instead of '=='.
You should make it clear that that's not the case like:
| while ((child = of_get_next_child(np, child)) != NULL)
Lothar Waßmann
--
___________________________________________________________
Ka-Ro electronics GmbH | Pascalstraße 22 | D - 52076 Aachen
Phone: +49 2408 1402-0 | Fax: +49 2408 1402-10
Geschäftsführer: Matthias Kaussen
Handelsregistereintrag: Amtsgericht Aachen, HRB 4996
www.karo-electronics.de | info@...o-electronics.de
___________________________________________________________
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists