lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:	Tue, 03 Dec 2013 10:50:05 -0700
From:	Stephen Warren <swarren@...dotorg.org>
To:	Dan Williams <dan.j.williams@...el.com>,
	Vinod Koul <vinod.koul@...el.com>
CC:	andriy.shevchenko@...el.com, dmaengine@...r.kernel.org,
	linux-kernel@...r.kernel.org, Stephen Warren <swarren@...dia.com>
Subject: Re: [PATCH V4] dma: add channel request API that supports deferred
 probe

On 11/26/2013 10:04 AM, Stephen Warren wrote:
> From: Stephen Warren <swarren@...dia.com>
> 
> dma_request_slave_channel() simply returns NULL whenever DMA channel
> lookup fails. Lookup could fail for two distinct reasons:
> 
> a) No DMA specification exists for the channel name.
>    This includes situations where no DMA specifications exist at all, or
>    other general lookup problems.
> 
> b) A DMA specification does exist, yet the driver for that channel is not
>    yet registered.
> 
> Case (b) should trigger deferred probe in client drivers. However, since
> they have no way to differentiate the two situations, it cannot.
> 
> Implement new function dma_request_slave_channel_reason(), which performs
> identically to dma_request_slave_channel(), except that it returns an
> error-pointer rather than NULL, which allows callers to detect when
> deferred probe should occur.
> 
> Eventually, all drivers should be converted to this new API, the old API
> removed, and the new API renamed to the more desirable name. This patch
> doesn't convert the existing API and all drivers in one go, since some
> drivers call dma_request_slave_channel() then dma_request_channel() if
> that fails. That would require either modifying dma_request_channel() in
> the same way, or adding extra error-handling code to all affected
> drivers, and there are close to 100 drivers using the other API, rather
> than just the 15-20 or so that use dma_request_slave_channel(), which
> might be tenable in a single patch.
> 
> acpi_dma_request_slave_chan_by_name() doesn't currently implement
> deferred probe. It should, but this will be addressed later.
> 
> Acked-by: Dan Williams <dan.j.williams@...el.com>
> Signed-off-by: Stephen Warren <swarren@...dia.com>
> ---
> v4:
> * Add {} around both branches in of_dma_request_slave_channel().
> v3:
> * s/_or_err/_reason/ in the new API name.
> * Simplify changes to of_dma_request_slave_channel() so that the new
>   "bool defer" parameter is not needed.
> * Revert changes to acpi-dma.c and handle the return value conversion
>   in dma_request_slave_channel_reason() instead.
> * Mention that acpi_dma_request_slave_chan_by_name() should implement
>   deferred probe, but that will happen later.
> v2:
> * include <linux/err.h> in <linux/dmaengine.h>
> * Return -ENODATA if slave_id or chan_id out-of-range.
> * Return an error-pointer not NULL if we can't find a matching DMA
>   controller or translate the channel.
> 
> This patch is a dependency for:
> * A series that reworks many of the Tegra drivers.
> * A series that enhances ASoC's dmaengine code to support deferred probe.
> 
> As such, it needs to go into a topic branch on its own, based directly
> on 3.13-rc1. If the DMA maintainers ack the patches I'm happy to create
> this topic branch myself and send a pull request to the DMA tree. Or the
> patches can be applied to a topic branch by the DMA maintainers and I
> will merge their topic branch into the Tegra rework branch that I
> mentioned.

Vinod, does this patch look OK to you? Are you able to stage it into a
topic branch that I can pull into the Tegra tree as a dependency?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ