[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <52C58EA7.2090107@citrix.com>
Date: Thu, 2 Jan 2014 16:07:03 +0000
From: David Vrabel <david.vrabel@...rix.com>
To: Konrad Rzeszutek Wilk <konrad.wilk@...cle.com>
CC: <linux-kernel@...r.kernel.org>, <xen-devel@...ts.xenproject.org>,
<boris.ostrovsky@...cle.com>, <stefano.stabellini@...citrix.com>,
<mukesh.rathor@...cle.com>
Subject: Re: [PATCH v12 09/18] xen/pvh: Secondary VCPU bringup (non-bootup
CPUs)
On 01/01/14 04:35, Konrad Rzeszutek Wilk wrote:
> From: Mukesh Rathor <mukesh.rathor@...cle.com>
>
> The VCPU bringup protocol follows the PV with certain twists.
> From xen/include/public/arch-x86/xen.h:
>
> Also note that when calling DOMCTL_setvcpucontext and VCPU_initialise
> for HVM and PVH guests, not all information in this structure is updated:
>
> - For HVM guests, the structures read include: fpu_ctxt (if
> VGCT_I387_VALID is set), flags, user_regs, debugreg[*]
>
> - PVH guests are the same as HVM guests, but additionally use ctrlreg[3] to
> set cr3. All other fields not used should be set to 0.
>
> This is what we do. We piggyback on the 'xen_setup_gdt' - but modify
> a bit - we need to call 'load_percpu_segment' so that 'switch_to_new_gdt'
> can load per-cpu data-structures. It has no effect on the VCPU0.
>
> We also piggyback on the %rdi register to pass in the CPU number - so
> that when we bootup a new CPU, the cpu_bringup_and_idle will have
> passed as the first parameter the CPU number (via %rdi for 64-bit).
[...]
> --- a/arch/x86/xen/enlighten.c
> +++ b/arch/x86/xen/enlighten.c
> @@ -1413,14 +1413,19 @@ static void __init xen_boot_params_init_edd(void)
> * Set up the GDT and segment registers for -fstack-protector. Until
> * we do this, we have to be careful not to call any stack-protected
> * function, which is most of the kernel.
> + *
> + * Note, that it is refok - b/c the only caller of this after init
Please spell out 'because' in full. b/c is too hard to read. Also list
the callers (cpu_bringup_and_idle() I guess).
> + * is PVH which is not going to use xen_load_gdt_boot or other
> + * __init functions.
> */
> -static void __init xen_setup_gdt(void)
> +void __init_refok xen_setup_gdt(int cpu)
__ref seems to be the correct section marker for this.
David
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@...r.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Powered by blists - more mailing lists